Left-aligned image causes miscalculated containing box size

RESOLVED INVALID

Status

()

RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: moshe+mozilla, Assigned: attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When an image is left-aligned, and text wraps around it but does not extend to
the bottom of the image, the containing box is drawn to end at the bottom of the
text, not at the bottom of the image, even though the image is taller than the text.
See URL for a clear demonstration of problem.

Comment 1

16 years ago
This is correct behaviour. 'align="left"' (a deprecated attribute) causes the
image to float left (equivalent to 'style="float: left;"') and the image is
therefore taken out of the normal flow, and the block box enclosing the image
flows vertically as if the image doesn't exist.

References:
http://www.w3.org/TR/html401/struct/objects.html#adef-align-IMG
http://www.w3.org/TR/html401/present/graphics.html#floating
http://www.w3.org/TR/html401/present/graphics.html#h-15.1.3
http://www.w3.org/TR/REC-CSS2/visuren.html#floats

Comment 2

16 years ago
Oh, and Mozilla's behaviour is consistent with that of other browsers (IE,
Opera, etc...)

Comment 3

16 years ago
Should this be marked invalid then ?

Comment 4

16 years ago
-> invalid, since everyone seems to accept comment #1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.