Closed Bug 1664949 Opened 2 months ago Closed 2 months ago

Themes stopped applying correctly in synced browser profiles

Categories

(Toolkit :: Add-ons Manager, defect)

Desktop
All
defect

Tracking

()

RESOLVED FIXED
82 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- unaffected
firefox82 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

The code in bug 1660557 started clearing the extensions.activeThemeID pref when it shouldn't do that.

Blocks: 1663663

Patch up in https://phabricator.services.mozilla.com/D90194 (not obvious while phabbugz is broken)

Before bug 1660557, this was actually clearing an old migration pref, but now
it's clearing the actual theme pref used by Sync.

Attachment #9175730 - Attachment description: Bug 1664949 - don't clear the active theme pref on startup so it gets synced wrong, r?zombie → Bug 1664949 - don't clear the active theme pref on startup so it gets synced wrong, r?zombie!,mixedpuppy!
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3f1747588a69
don't clear the active theme pref on startup so it gets synced wrong, r=zombie,mixedpuppy

From local logs:

pid:9556 console.log: "Shockwave FlashFlash plug-in for testing purposes." [is being installed]

Ceterum autem censeo Flash delendam esse

Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6436125ed780
don't clear the active theme pref on startup so it gets synced wrong, r=zombie,mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
You need to log in before you can comment on or make changes to this bug.