Closed Bug 1665049 Opened 1 year ago Closed 9 months ago

Remove browser.urlbar.update2 branch preferences

Categories

(Firefox :: Address Bar, task, P3)

task
Points:
3

Tracking

()

RESOLVED FIXED
86 Branch
Iteration:
85.2 - Nov 30 - Dec 13
Tracking Status
firefox86 --- fixed

People

(Reporter: harry, Assigned: mak)

References

Details

Attachments

(4 files)

There are quite a few tests and subtests to be removed. Many have _legacy in their titles. Searching for _legacy and update2 should be enough to find them all.

Summary: Remove update2 preference → Remove browser.urlbar.update2 branch preferences
Blocks: 1665066
Severity: -- → S3
Priority: -- → P3
No longer blocks: 1665048
Depends on: 1665048

I'm removing update2.tabToComplete in bug 1678138.
update2.engineAliasRefresh is still not complete and used only in search.js, it's likely we'll rename it in the future, for now we should leave it alone.
update2.disableOneOffsHorizontalKeyNavigation can probably be removed, so far I have not seen any major backlash from this change.
update2.emptySearchBehavior should probably stay for a while yet, we don't yet have full spec of what to do here, may want to experiment further.
update2.restyleBrowsingHistoryAsSearch can probably go, again I didn't see any major problems reported.
update2.oneOffsRefresh, I'm not sure about this, one side it's the pref that allows to remove the most code, on the other side we didn't address all the concerns with the loss of efficiency (like even just making the shift override more discoverable).

Thus, we can immediately remove update2, update2.disableOneOffsHorizontalKeyNavigation, update2.restyleBrowsingHistoryAsSearch, and file a follow-up for update2.oneOffsRefresh.

Assignee: nobody → mak
Status: NEW → ASSIGNED
Iteration: --- → 85.2 - Nov 30 - Dec 13
Points: 3 → 1
Points: 1 → 2

These should land after the merge anyway. We can discuss update2.oneOffsRefresh on Monday meeting.

Depends on D99486

Per today discussion with PM and UX I'll also remove update2.oneOffsRefresh

Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/028644c366d5
Remove browser.urlbar.update2.disableOneOffsHorizontalKeyNavigation. r=harry
https://hg.mozilla.org/integration/autoland/rev/011f54945acb
Remove browser.urlbar.update2.restyleBrowsingHistoryAsSearch. r=harry
https://hg.mozilla.org/integration/autoland/rev/156a323cd31a
Remove browser.urlbar.update2.oneOffsRefresh. r=harry
https://hg.mozilla.org/integration/autoland/rev/fd06f6552ad0
Remove browser.urlbar.update2. r=harry

Backed out for causing bustages in browser.ini

Backout link: https://hg.mozilla.org/integration/autoland/rev/c4bfcfa0e918abde877834535091344eacb3fcea

Push with failures: https://treeherder.mozilla.org/jobs?repo=autoland&selectedTaskRun=LqeFtCcLQ_aabAPdyU27rA.0&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=fd06f6552ad0d2326281869fb25603326bb18339

Failure log: https://treeherder.mozilla.org/logviewer?job_id=324910950&repo=autoland&lineNumber=1198

"INFO - mozbuild.frontend.reader.SandboxValidationError:
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - ==============================
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - FATAL ERROR PROCESSING MOZBUILD FILE
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - ==============================
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - The error occurred while processing the following file or one of the files it includes:
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - /builds/worker/checkouts/gecko/browser/components/touchbar/moz.build
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - The error occurred when validating the result of the execution. The reported error is:
[task 2020-12-18T09:39:31.461Z] 09:39:31 ERROR - Error processing test manifest file /builds/worker/checkouts/gecko/browser/components/touchbar/tests/browser/browser.ini: Traceback (most recent call last):
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/frontend/emitter.py", line 1815, in _process_test_manifest
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - context,
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - mozbuild.frontend.reader.SandboxValidationError:
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - ==============================
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - FATAL ERROR PROCESSING MOZBUILD FILE
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - ==============================
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - The error occurred while processing the following file or one of the files it includes:
[task 2020-12-18T09:39:31.461Z] 09:39:31 INFO - /builds/worker/checkouts/gecko/browser/components/touchbar/moz.build
[task 2020-12-18T09:39:31.462Z] 09:39:31 INFO - The error occurred when validating the result of the execution. The reported error is:
[task 2020-12-18T09:39:31.462Z] 09:39:31 INFO - Test manifest (/builds/worker/checkouts/gecko/browser/components/touchbar/tests/browser/browser.ini) lists test that does not exist: browser_touchbar_searchrestrictions_legacy.js
[task 2020-12-18T09:39:32.084Z] 09:39:32 INFO - Error running mach:
[task 2020-12-18T09:39:32.084Z] 09:39:32 INFO - ['--log-no-times', 'build', '-v']
[task 2020-12-18T09:39:32.084Z] 09:39:32 INFO - The error occurred in code that was called by the mach command. This is either
[task 2020-12-18T09:39:32.084Z] 09:39:32 INFO - a bug in the called code itself or in the way that mach is calling it.
[task 2020-12-18T09:39:32.084Z] 09:39:32 INFO - You can invoke |./mach busted| to check if this issue is already on file. If it
[task 2020-12-18T09:39:32.084Z] 09:39:32 INFO - isn't, please use |./mach busted file build| to report it. If |./mach busted| is
[task 2020-12-18T09:39:32.085Z] 09:39:32 INFO - misbehaving, you can also inspect the dependencies of bug 1543241.
[task 2020-12-18T09:39:32.085Z] 09:39:32 INFO - If filing a bug, please include the full output of mach, including this error
[task 2020-12-18T09:39:32.085Z] 09:39:32 INFO - message.
[task 2020-12-18T09:39:32.085Z] 09:39:32 INFO - The details of the failure are as follows:
[task 2020-12-18T09:39:32.085Z] 09:39:32 INFO - Exception: Process executed with non-0 exit code 1: ['/builds/worker/workspace/obj-build/_virtualenvs/init_py3/bin/python', '/builds/worker/checkouts/gecko/configure.py']
[task 2020-12-18T09:39:32.086Z] 09:39:32 INFO - File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/build_commands.py", line 154, in build
[task 2020-12-18T09:39:32.086Z] 09:39:32 INFO - append_env=append_env,
[task 2020-12-18T09:39:32.086Z] 09:39:32 INFO - File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/controller/building.py", line 1144, in build
[task 2020-12-18T09:39:32.086Z] 09:39:32 INFO - append_env=append_env,
[task 2020-12-18T09:39:32.086Z] 09:39:32 INFO - File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/controller/building.py", line 1528, in configure
[task 2020-12-18T09:39:32.086Z] 09:39:32 INFO - append_env=append_env,
[task 2020-12-18T09:39:32.087Z] 09:39:32 INFO - File "/builds/worker/checkouts/gecko/python/mozbuild/mozbuild/base.py", line 887, in _run_command_in_objdir
[task 2020-12-18T09:39:32.087Z] 09:39:32 INFO - return self.run_process(cwd=self.topobjdir, **args)
[task 2020-12-18T09:39:32.087Z] 09:39:32 INFO - File "/builds/worker/checkouts/gecko/python/mach/mach/mixin/process.py", line 177, in run_process
[task 2020-12-18T09:39:32.087Z] 09:39:32 INFO - "Process executed with non-0 exit code %d: %s" % (status, args)
[task 2020-12-18T09:39:32.128Z] 09:39:32 ERROR - Return code: 1"

Flags: needinfo?(mak)

I forgot to remove the test from browser.ini because it's a Mac only test, that I tend to skip on Try due to its slowness :(

Flags: needinfo?(mak)
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/a0cb80f2605d
Remove browser.urlbar.update2.disableOneOffsHorizontalKeyNavigation. r=harry
https://hg.mozilla.org/integration/autoland/rev/20b2b380e8a6
Remove browser.urlbar.update2.restyleBrowsingHistoryAsSearch. r=harry
https://hg.mozilla.org/integration/autoland/rev/360c06f3d705
Remove browser.urlbar.update2.oneOffsRefresh. r=harry
https://hg.mozilla.org/integration/autoland/rev/b49eab9c9c08
Remove browser.urlbar.update2. r=harry
Points: 2 → 3
Regressions: 1683311

i (and presumably other people since there are already complaints on reddit) still use update2.oneOffsRefresh. i don't want to have to click the one-off button AND hit enter. what's the point of even having the icons if you still have to use the keyboard, when there are already shortcut strings to select a one-off search engine?

(In reply to shmediaproductions from comment #13)

i (and presumably other people since there are already complaints on reddit) still use update2.oneOffsRefresh. i don't want to have to click the one-off button AND hit enter.

You can override the behavior by holding the SHIFT key while clicking or, if you selected a shortcut button with the keyboard, you can SHIFT+Enter. SHIFT always works as an action override in the urlbar (for example also on Switch to tab).
Since you just typed a query, your hand is already on the keyboard.
That's a supported option and we're looking into ways to make it more discoverable. The pref was not a supported option, it was just a rollout pref.
Before this removal, we evaluated the behavior and feedback, we ran user studies and no one was confused or suprised by the new behavior. It's one of those things that unfortunately require a change of habits, and thus it's annoying and frustrating at the beginning. Everyone is aware of that.

(In reply to Marco Bonardo [:mak] from comment #14)

(In reply to shmediaproductions from comment #13)

i (and presumably other people since there are already complaints on reddit) still use update2.oneOffsRefresh. i don't want to have to click the one-off button AND hit enter.

You can override the behavior by holding the SHIFT key while clicking or, if you selected a shortcut button with the keyboard, you can SHIFT+Enter. SHIFT always works as an action override in the urlbar (for example also on Switch to tab).
Since you just typed a query, your hand is already on the keyboard.
That's a supported option and we're looking into ways to make it more discoverable. The pref was not a supported option, it was just a rollout pref.
Before this removal, we evaluated the behavior and feedback, we ran user studies and no one was confused or suprised by the new behavior. It's one of those things that unfortunately require a change of habits, and thus it's annoying and frustrating at the beginning. Everyone is aware of that.

Thanks, not sure how I didn't notice that. Is that implemented by line 203 of UrlbarSearchOneOffs.jsm? If that's all then I think I can make a userscript to make that the default behavior for my profile.

(In reply to shmediaproductions from comment #15)

Thanks, not sure how I didn't notice that. Is that implemented by line 203 of UrlbarSearchOneOffs.jsm? If that's all then I think I can make a userscript to make that the default behavior for my profile.

Pretty much, yes.

Thanks, I eventually figured it out. If anyone from the future wants this, here's the script I cobbled together. It restores the previous behavior of initiating a search when left-clicking a search one-off button, but leaves the default behavior for the bookmarks/history/tab buttons since those only pull up suggestions. There might be cleaner ways to achieve some of this, the unminified source is here if someone wants to improve it. Requires a way to load privileged js to access the code modules of course, I use alice0775's autoconfig loader but there might still be others.

You need to log in before you can comment on or make changes to this bug.