Closed Bug 1665389 Opened 7 months ago Closed 5 months ago

Bookmarks should be stored on the bookmarks toolbar by default

Categories

(Firefox :: Bookmarks & History, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
84 Branch
Tracking Status
firefox84 --- verified

People

(Reporter: jaws, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

With the changes in the bugs blocking bug 1665353, the bookmarks toolbar should be the new default location for bookmarks. While changing the default, we should introduce a new preference in about:preferences to let the user change the default location in case they want to keep "Other Bookmarks" as the default location. This also addresses a longstanding issue where people wanted other folders to be the default location since they will have the ability to change it from Preferences.

We will also change the overflow button to open the Bookmarks sidebar with the Bookmarks Toolbar folder expanded.

This is effectively a duplicate of bug 1412263. There's also bug 1432604 about allowing it to be the last used location rather than always defaulting to the same.

Have the comments/duplicates on those been considered?

Also bug 1425290 points out there may be more than one location to update the default bookmarking location for.

Flags: needinfo?(jaws)

Thanks Mark, yes this covers bug 1412263 and also adds in the Bookmarks Toolbar bit. I will talk to Aaron and Katie from UX about adding an option in Preferences to preselect the last used location, so it could be:

Default bookmark location:
[Bookmarks toolbar v ]
[Bookmarks menu ]
[Other bookmarks ]
[Select a folder... ]

[ ] Store bookmarks in last used location

Flags: needinfo?(jaws)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Assignee: jaws → gijskruitbosch+bugs

This adds a pref containing a parent GUID, a lazy pref getter that validates
that GUID (asynchronously), and starts using the pref from the
PlacesCommandHook.

It also sets the future default (toolbar) into firefox.js, and overrides
that on the default branch when the new 2020 bookmarks pref is not set.

Finally, it sets the pref to the unfiled default for existing profiles
with a migration. If we end up delaying shipping, we'll need to
update that migration - but I don't see a way around that.

Blocks: 1425290
Blocks: 1674515
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/09f049232773
create bookmarks on the toolbar by default, r=mak,jaws
Flags: needinfo?(gijskruitbosch+bugs)
Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/109da131e1e8
create bookmarks on the toolbar by default, r=mak,jaws
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch

Hello,

Verified this issue on Fx 84.0b1 on Win 10, ubuntu and mac os.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1676037
You need to log in before you can comment on or make changes to this bug.