If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No helper application shown when clicking on link with MIME content

RESOLVED WORKSFORME

Status

Core Graveyard
File Handling
--
major
RESOLVED WORKSFORME
15 years ago
a year ago

People

(Reporter: Reinhold Bader, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

When clicking, e. g. on a PDF file, the Download Window appears without any
choice for either starting the associated application (e. g. acroread) or
saving the file to disk. Nothing happens when the OK button (which is present)
is pressed.

Reproducible: Always

Steps to Reproduce:
1. open the URL http://www.mpi-forum.org/docs/docs.html
2. click on the link "PDF" near the top of this page
3. Change to window "Downloading ..."


Actual Results:  
No checkboxes for
* opening with helper application
* saving to disk

Expected Results:  
offer checkboxes and opening application or downloading to file system
according to user choice

Comment 1

15 years ago
what theme are you using?  If not classic/modern, what version?
Assignee: blaker → law
Component: Download Manager → File Handling
QA Contact: sairuh → petersen

Comment 2

15 years ago
Reinhold, can you reproduce this with a current version of mozilla? Could you do
the following:

1) Open Edit->Preferences->Navigator->Helper Applications
2) Click "Reset" to clear your file-opening preferences.

After doing this, please report whether you are still having this problem.

Comment 3

15 years ago
Reinhold responded in email:

-------------------------
Hello,

    yes, doing this does seem to fix the problem (for now). Generally my
    impression is that the Edit-->Preferences entries easily get
    corrupted (which presumably is the reason the Reset button's
    available). However, on at least two occasions things got so bad that
    I had to throw away the complete .mozilla configuration (I guess
    an expert would have fixed things, but I'm not one).

   Thanks for your help with this ...
-------------------------

I'm going to go ahead and resolve this worksforme. It's possible that you
inadvertantly saved a "preference tow download pdf files previously, possibly
without being aware of it (it's set by a checkbox in the "what do you want to do
with this file" dialog). At this point, it's probably impossible to determine
whether your prefs were set that way through the user interface or by some bug.

Thanks for following up. If the problem reoccurs, please feel free to reopen
this report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.