Closed Bug 1665505 Opened 1 year ago Closed 1 year ago

Perma [tier2][fission] webconsole/test/browser/browser_webconsole_css_error_impacted_elements.js | A promise chain failed to ... : Can not send request 'finalize' because front 'customhighlighter' is already destroyed. - FrontClassWithSpec.js:28:15

Categories

(DevTools :: Console, defect, P5)

defect

Tracking

(firefox-esr78 unaffected, firefox81 unaffected, firefox82 wontfix, firefox83 fixed)

RESOLVED FIXED
83 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox81 --- unaffected
firefox82 --- wontfix
firefox83 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nchevobbe)

References

(Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell unknown])

Attachments

(1 file)

Filed by: csabou [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=315863055&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/I3scgmcXSmGiOG1pqwjXpQ/runs/0/artifacts/public/logs/live_backing.log


[task 2020-09-16T17:33:11.935Z] 17:33:11     INFO - TEST-PASS | devtools/client/webconsole/test/browser/browser_webconsole_css_error_impacted_elements.js | The main process DevToolsServer has no pending connection when the test ends - 
[task 2020-09-16T17:33:11.935Z] 17:33:11     INFO - Console message: [JavaScript Error: "Error: Can not send request 'finalize' because front 'customhighlighter' is already destroyed." {file: "resource://devtools/shared/protocol/Front/FrontClassWithSpec.js" line: 28}]
[task 2020-09-16T17:33:11.935Z] 17:33:11     INFO - Buffered messages finished
[task 2020-09-16T17:33:11.936Z] 17:33:11     INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser/browser_webconsole_css_error_impacted_elements.js | A promise chain failed to handle a rejection: Can not send request 'finalize' because front 'customhighlighter' is already destroyed. - stack: generateRequestMethods/</frontProto[name]@resource://devtools/shared/protocol/Front/FrontClassWithSpec.js:28:15
[task 2020-09-16T17:33:11.936Z] 17:33:11     INFO - destroyHighlighters@resource://devtools/client/fronts/inspector.js:101:38
[task 2020-09-16T17:33:11.936Z] 17:33:11     INFO - destroy@resource://devtools/client/fronts/inspector.js:94:10
[task 2020-09-16T17:33:11.937Z] 17:33:11     INFO - destroy@resource://devtools/shared/protocol/Pool.js:189:17
[task 2020-09-16T17:33:11.937Z] 17:33:11     INFO - destroy@resource://devtools/shared/protocol/Front.js:65:11
[task 2020-09-16T17:33:11.938Z] 17:33:11     INFO - _destroyTarget@resource://devtools/client/fronts/targets/target-mixin.js:695:13
[task 2020-09-16T17:33:11.938Z] 17:33:11     INFO - Rejection date: Wed Sep 16 2020 17:33:11 GMT+0000 (Coordinated Universal Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 265
[task 2020-09-16T17:33:11.940Z] 17:33:11     INFO - Stack trace:
[task 2020-09-16T17:33:11.940Z] 17:33:11     INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:265
[task 2020-09-16T17:33:11.940Z] 17:33:11     INFO - chrome://mochikit/content/browser-test.js:nextTest:615
[task 2020-09-16T17:33:11.940Z] 17:33:11     INFO - chrome://mochikit/content/browser-test.js:testScope/test_finish/<:1512
[task 2020-09-16T17:33:11.941Z] 17:33:11     INFO - chrome://mochikit/content/browser-test.js:run:1427
[task 2020-09-16T17:33:11.941Z] 17:33:11     INFO - GECKO(7322) | MEMORY STAT | vsize 3867MB | residentFast 500MB | heapAllocated 201MB
[task 2020-09-16T17:33:11.942Z] 17:33:11     INFO - TEST-OK | devtools/client/webconsole/test/browser/browser_webconsole_css_error_impacted_elements.js | took 2257ms```
Summary: Intermittent devtools/client/webconsole/test/browser/browser_webconsole_css_error_impacted_elements.js | A promise chain failed to ... : Can not send request 'finalize' because front 'customhighlighter' is already destroyed. - FrontClassWithSpec.js:28:15 → Perma fiss devtools/client/webconsole/test/browser/browser_webconsole_css_error_impacted_elements.js | A promise chain failed to ... : Can not send request 'finalize' because front 'customhighlighter' is already destroyed. - FrontClassWithSpec.js:28:15

No, this was a Marionette unit test only change which doesn't have to do anything with mochitests. So this assumption is wrong. Something else needs to be responsible for that.

Flags: needinfo?(hskupin)
No longer regressed by: 1665210
Summary: Perma fiss devtools/client/webconsole/test/browser/browser_webconsole_css_error_impacted_elements.js | A promise chain failed to ... : Can not send request 'finalize' because front 'customhighlighter' is already destroyed. - FrontClassWithSpec.js:28:15 → Perma fiss [tier2][fission] webconsole/test/browser/browser_webconsole_css_error_impacted_elements.js | A promise chain failed to ... : Can not send request 'finalize' because front 'customhighlighter' is already destroyed. - FrontClassWithSpec.js:28:15
Summary: Perma fiss [tier2][fission] webconsole/test/browser/browser_webconsole_css_error_impacted_elements.js | A promise chain failed to ... : Can not send request 'finalize' because front 'customhighlighter' is already destroyed. - FrontClassWithSpec.js:28:15 → Perma [tier2][fission] webconsole/test/browser/browser_webconsole_css_error_impacted_elements.js | A promise chain failed to ... : Can not send request 'finalize' because front 'customhighlighter' is already destroyed. - FrontClassWithSpec.js:28:15

we can probably fix the test here

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa68a619efcd
Check that highlighter isn't destroyed before calling finalize. r=ochameau.
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch

Set release status flags based on info from the regressing bug 1664438

Flags: needinfo?(poirot.alex)

The patch landed in nightly and beta is affected.
:nchevobbe, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(nchevobbe)

This is a test only, fission only issue, so I think it's not worth doing the uplift

Flags: needinfo?(nchevobbe)
You need to log in before you can comment on or make changes to this bug.