Closed Bug 1665574 Opened 1 year ago Closed 1 year ago

Network tab broken, IndexSizeError: Index or size is negative or greater than the allowed amount

Categories

(DevTools :: Netmonitor, defect)

80 Branch
defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: t.smelik, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

Open dev tools
Open network tab
Click the "Reload" button in the tab or manually reload the page

I suspect this might somehow have been been caused by changing by screen resolution as this started happening after changing the resolution while working remotely. This error also does not occur if I change my screen resolution from the usual 4K to HD, but if I revert that change the error reappears.

Actual results:

The contents of the the network tab disappear (including the toolbar), resulting in An entirely empty tab


Two errors appear in the browser console:

DOMException: Index or size is negative or greater than the allowed amount react-dom.js:12769:13
React 19
Redux 9
eventTelemetryMiddleware resource://devtools/client/netmonitor/src/middleware/event-telemetry.js:31
throttlingMiddleware resource://devtools/client/netmonitor/src/middleware/throttling.js:18
recordingMiddleware resource://devtools/client/netmonitor/src/middleware/recording.js:24
batchingMiddleware resource://devtools/client/netmonitor/src/middleware/batching.js:57
prefsMiddleware resource://devtools/client/netmonitor/src/middleware/prefs.js:27
thunkWithOptions Redux
requestBlockingMiddleware resource://devtools/client/netmonitor/src/middleware/request-blocking.js:39
resizeWaterfall resource://devtools/client/netmonitor/src/components/request-list/RequestListHeader.js:723
_resizeTimerId resource://devtools/client/netmonitor/src/components/request-list/RequestListHeader.js:243

and

IndexSizeError: Index or size is negative or greater than the allowed amount WaterfallBackground.js:68

Expected results:

Show the network requests

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Netmonitor
Product: Firefox → DevTools

Thanks for reporting!
I've not been able to reproduce on my Mac OS.

t.smelik,
Would you be able to do a quick screencast or video that shows the issue?
That would be really helpful

Flags: needinfo?(t.smelik)

I noticed I was zoomed in in the dev tools panel (not the web page itself), resetting that to 100% somehow fixed the problem. Unfortunately, I haven't managed to reproduce the problem since. If it happens again, I'll make sure to record it.

Flags: needinfo?(t.smelik)

I can't reproduce that either (Win 10, current Nightly)
Honza

Hi t.smelik,
Since we have not been able to reproduce, i'll close this now.
Please feel free to reopen if you hit the issue again.

Thanks

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID

Am experiencing the same issue

Bug report 1677984

You need to log in before you can comment on or make changes to this bug.