Closed Bug 1665579 Opened 10 months ago Closed 10 months ago

Crash in [@ js::jit::MaybeEnterJit] with javascript.options.warp enabled

Categories

(Core :: JavaScript Engine: JIT, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1665432
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- unaffected
firefox82 --- disabled

People

(Reporter: aryx, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: crash)

Crash Data

After setting javascript.options.warp to true and restarting Firefox 82.0a1 20200916153738 (32-bit) on Windows 8.1, it always crashes on startup.

Crash report: https://crash-stats.mozilla.org/report/index/6c946cea-4e24-4bc8-abb4-b02f70200917

Top 10 frames of crashing thread:

0  @0xffffff8c 
1  @0x47df90bf 
2  @0x27f3071a 
3 xul.dll js::jit::MaybeEnterJit js/src/jit/Jit.cpp:197
4 xul.dll js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:637
5 xul.dll js::jit::DoCallFallback js/src/jit/BaselineIC.cpp:3027
6 xul.dll trunc 
7  @0x4951708f 
8  @0x27f305dc 
9  @0x27f5dc54 

This is 99% likely a duplicate of bug 1665432. It also fails jit-tests, but we only run those with Warp in CI on Linux64 atm. Sorry about that...

Depends on: 1665432

Yeah, this is definitely bug 1665432.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1665432
You need to log in before you can comment on or make changes to this bug.