Closed Bug 1666050 Opened 2 years ago Closed 2 years ago

Alignment and line height issue for every text element, including buttons, fields, descriptions, etc.

Categories

(Thunderbird :: Theme, defect, P3)

Desktop
macOS

Tracking

(thunderbird_esr78 unaffected, thunderbird86? affected)

RESOLVED FIXED
87 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird86 ? affected

People

(Reporter: aleca, Assigned: aleca)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image comparison.png

This issue seems to happen only on macOS, but I haven't tested Windows.

It seems that all the elements using text aren't properly aligned anymore.
Every button, text field, description, or label is visually misaligned.

This issue doesn't affect 78.

Severity: -- → S4

The today pane spacing comes from https://searchfox.org/comm-central/source/calendar/base/themes/common/widgets/calendar-widgets.css#25 changed in bug 1621135. Maybe you know the patch author. ;-)

The other things I think I don't see.

Priority: -- → P3
Assignee: nobody → alessandro
Attached image AlignmentTextButton.png

Tested on macOS, Firefox 85.0 on the extended bookmark dropdown the text are misaligned, not centered in Remove Bookmark (Cancel) and Done buttons.

(In reply to Timea Zsoldos [:zstimi/tzsoldos], Desktop Release QA from comment #2)

Created attachment 9198594 [details]
AlignmentTextButton.png

Tested on macOS, Firefox 85.0 on the extended bookmark dropdown the text are misaligned, not centered in Remove Bookmark (Cancel) and Done buttons.

That seems to be a different issue only related to Firefox.
All the alignment issues in Thunderbird have been solved.

Taking care of the missing padding issue on the Today Pane just a bunch of months after I broke it...

Attachment #9200167 - Flags: review?(richard.marti)
Status: NEW → ASSIGNED

Comment on attachment 9200167 [details] [diff] [review]
1666050-today-pane-items.diff

Yeah, looks better.

Attachment #9200167 - Flags: review?(richard.marti) → review+
Target Milestone: --- → 87 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/be7e6bd4c4e3
Fix sizing of Today Pane agenda treechildren. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.