browsing install location hangs when default drive doesn't exist

RESOLVED WORKSFORME

Status

SeaMonkey
Installer
--
critical
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Xin Zheng, Unassigned)

Tracking

({hang})

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla 1.0 1.1a 1.1b 1.1

When I try to install Mozilla 1.0 1.1a 1.1b or 1.1, and press browse button as 
i have to as my location is a drive nolonger in existence, it crashs.

Reproducible: Always

Steps to Reproduce:
1.execute mozilla installer
2.click on next and agree etc.
3.then browse

Actual Results:  
crashs? ;)

Expected Results:  
open up the browse window

Updated

16 years ago
Keywords: crash

Comment 1

16 years ago
Reporter sez: "as i have to as my location is a drive nolonger in existence" 
does this mean that the installer defaults to an old installation directory that
no longer is a valid path?

Comment 2

16 years ago
I cant crash...

Mozilla always default to:
"C:\Program Files\mozilla.org\Mozilla"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

16 years ago
I was adviced to reopen this bug by Benjamin Smedberg.

The bug presists, I will attempt to explain it more thoroughly this time.

I had many partitions once, and someone one of the windows drive got assigned 
the letter H, which i used for installed programs.  I installed mozilla 1.0a I 
think it was on this drive, but after deleting some other partitions, some how 
what was known as the H drive got renamed to the C drive.  As this caused bad 
address errors all the time with programs on that drive, I decided to uninstall 
most programs and reinstall them again.  Which I did, and worked ok untill I 
tried to install mozilla 1.1a, which gave me a default location of h:\program 
files\mozilla.org\mozilla, which ofcause can not be created, and when I tried 
to change the location by pressing 'browse' it just hanged, and eventually 
crashed.

I'd really like to use mozilla on windows again, it has put me off for using 
the last two releases already:( 

much appreciation and regards
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
If your windows add/remove programs control panel utility still shows Mozilla,
uninstall it to clean out registry settings. Failing that edit your windows
registry and by hand delete the key HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org and
any subkeys.  (Do not delete the key HKLM\SOFTWARE\Mozilla -- that's shared by
any Gecko-based product, not just the versions released by mozilla.org)

The above is a workaround to get you going again, not a fix for this bug.
reversing this, the bug can be tested by modifying existing registry entries to
point at a non-existant drive (look for an "Install Directory" value under a
Main key, I think).

http://lxr.mozilla.org/mozilla/source/xpinstall/wizard/windows/setup/extra.c#3576
looks like it would go into an infinite loop if the drive didn't exist, but I
don't think that would get triggered by pressing the browse button (it's called
by disk space checking).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash → hang
Summary: crashed if i press browse to select installation location → browsing install location hangs when default drive doesn't exist
Keywords: nsbeta1+
(Reporter)

Comment 5

16 years ago
it works now that i have deleted mozilla.org registry folder, thanks alot.
I remind any latecomers not to interpret comment 5 as a signal to close
"WORKSFORME". The bug is still there, I just found Chrizh a workaround
Status: NEW → ASSIGNED

Comment 7

15 years ago
nsbeta1-, doesn't appear to be a typical problem
Keywords: nsbeta1+ → nsbeta1-
Product: Browser → Seamonkey

Updated

12 years ago
QA Contact: bugzilla → general
Assignee: dveditz → nobody
Status: ASSIGNED → NEW
Seamonkey and Firefox are using a new NSIS based installer. resolving this old bug, please reopen if you still get this with the new installer
Status: NEW → RESOLVED
Last Resolved: 16 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.