Certutil crashes reading from stdin

RESOLVED DUPLICATE of bug 136804

Status

NSS
Tools
RESOLVED DUPLICATE of bug 136804
16 years ago
16 years ago

People

(Reporter: Steve Parkinson, Assigned: Wan-Teh Chang)

Tracking

3.4.2
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Certutil is supposed to support adding certs from stdin, however, this now
crashes.

certutil -d . -A -t u,u,u, -a -n agent-3
Segmentation fault

  [1] PR_GetOpenFileInfo(0x0, 0xffbef428, 0x1, 0xff3e6694, 0x17998, 0x0), at
0xff30c9d0
=>[2] SECU_FileToItem(dst = 0xffbef4b0, src = (nil)), line 538 in "secutil.c"
  [3] SECU_ReadDERFromFile(der = 0xffbef53c, inFile = (nil), ascii = 1), line
619 in "secutil.c"
  [4] AddCert(slot = 0x247548, handle = 0x23da28, name = 0x21c590 "agent-3",
trusts = 0xffbef868 "u,u,u,", inFile = (nil), ascii = 1, emailcert = 0, pwdata =
0xffbef644), line 285 in "certutil.c"
  [5] main(argc = 9, argv = 0xffbef6fc), line 2864 in "certutil.c"
(Assignee)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

16 years ago
Steve, this is a known bug that will be fixed in
NSS 3.6.  You can use the -i option to work around
this.

*** This bug has been marked as a duplicate of 136804 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.