Browser window always opens in primary display on multiple monitor setup

RESOLVED WORKSFORME

Status

()

Core
XUL
--
trivial
RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: Tom Welch, Assigned: jag (Peter Annema))

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

When starting Mozilla, the browser window will open in the same position as it
was when closed from the last session if it was in the area of the primary
display.  However, if the browser was positioned in the secondary monitor on
exit the next time it is launched the left edge of the windows is positioned at
zero and the rest of the positioning is retained.

This behavior may not be seen when the primary display is to the left of the
secondary monitor as coordinates will still be positive on the secondary
display.  Also, the same behavior should be seen when the primary monitor is
located below the secondary except the top position will be adjusted to zero.

Reproducible: Always

Steps to Reproduce:
1. Open Mozilla browser
2. Move window to secondary display
3. Close Mozilla
4. Open Mozilla again.

Actual Results:  
Mozilla opened with the left edge of the window at coordinate zero on the
primary display.

Expected Results:  
It should have opened on the secondary display.  It's left coordinate should
have been something like -800.

Comment 1

16 years ago
The proper component for this bug is XP Toolkit: Widgets

This is almost a duplicate of Bug 21942, except that this bug deals with window
placement prefs.
Status: UNCONFIRMED → NEW
Ever confirmed: true
.
Assignee: asa → jaggernaut
Component: Browser-General → XP Toolkit/Widgets
QA Contact: asa → jrgm
Whiteboard: DUPEME
(Reporter)

Comment 3

16 years ago
So is the entire UI within the bounds of the XPToolkit?  There is apparently
(from the recent bugs I have found) a severe problem with Mozilla when dealing
with negative screen coordinates.  Whether it be window placement, mouse
hovering issues in a web document, or menu highlighting in the browser's menu,
the entire user interface (while still operable) breaks on a secondary monitor.

I get the feeling that somewhere there is code that saves the current mouse
coordinates for comparison during the next mouse message.  However, if the
current mouse coordinates are negative they are saved as zero.  What module
would contain that code?

Comment 4

16 years ago
*** Bug 170800 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
in bug 179745 comment 2, a user says that a new build cured a problem he had
with the browser "always popping up on the primary display instead of the
one where I closed it last". 

That sounds exactly like this bug. Can someone test it again with a new build?

Updated

14 years ago
Blocks: 236647

Comment 6

14 years ago
It's a platform independent bug. (tested on Linux)

Comment 7

11 years ago
WFM on Vista.
anyone else?

Comment 8

10 years ago
=> WFM 
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 9

6 years ago
This issue has returned with SeaMonkey for Mac 2.9.1. MacMini dual core 10.6.8 OS.

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.