Arabic in mozilla is written "not connected" and from left to right

RESOLVED FIXED

Status

()

Core
Layout: Text
--
major
RESOLVED FIXED
16 years ago
10 years ago

People

(Reporter: dror, Assigned: smontagu)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
in every arabic site the text is not connect as it should be and is written from
left to right instead of right ot left.


Very strange: in netscape 6.1+ the text is shown "connected" and from right to
left as it should be.

I have 3 computers and in everyone the arabic text is shown "ok" in netscape
6.1+ but not good in every version!!! of mozilla.

another prbolem regarding both netscape 6.1+ and mozilla is that the arabic texy
is not justefied as it should be. it is like (i will write it from left to right
in order to demonstrate the problem becasue i wirte now in english)

fldkgjhfdlk fkndklfddf fdslkgh dfkl
      fdkln kld fdk;lhnk; dflksh kldf klds h
   fdkljf k flk jflkg fkl; gj
                        klfdj kl;jfkl jgkfjn k;dljgnkfj l;kd
       dfkpljg kldfjglk; l
          kflj kl;df g
fihjfkd 

so understand there are 2 different problem (2 problem in mozilla, both
"connecting" and "left to right" and justification, and only the justificaition
problem in netscape 6.1+)

by the way, in all the computers i use full hebrew win98.
(Assignee)

Comment 1

16 years ago
This is probably a problem with our code to detect the platform's bidi
capabilities. On NT and above, if Windows has Hebrew support it also has Arabic
support, but it seems from what you are saying that this is not the case on 98,
so we will need to refine our detection.

AFAIK, Arabic works correctly in both Arabic Windows 98 and version with no Bidi
support at all; I will try to confirm that.
(Assignee)

Comment 2

16 years ago
Thanks to timeless I have seen a screenshot of Arabic on English Windows 98, and
the display is correct (except for known issues with the window title and
diacritic placement)
(Reporter)

Comment 3

16 years ago
I think win98 in hebrew has arabic support. if you download the arabic language
pack which comes with IE it is possible to view arabic in IE (it is possible
without the pack but only with one font thaoma very ugly and not writing) and in
Netscape 6.1+ (not in mozilla) and even to write well in arabic in mozilla's url
tab (not very useful) or in google's (or any other page tab) search tab shown in
mozilla.

By the way, the titles of arabic sites are shown well!!! (connected and from
right to left) in "navigator tabs". Therefore I think the problem is in
mozilla's way of showing arabic sites written in HTML and not in the basic
support of the OS.
(Assignee)

Comment 4

16 years ago
Thanks, that is useful information. We really need someone with a debugging
environment on Hebrew Win98 to investigate what exactly is going on here.
(Reporter)

Comment 5

15 years ago
I now have Mozilla 1.3 alpha and hebrew win98 and the problem is still here.

What's happening????????

Does nobody do smoething?

Waitnig for answer
(Assignee)

Comment 6

14 years ago
Created attachment 136158 [details] [diff] [review]
Patch v.0

At last I have a development system on Hebrew-enabled Win98. Here is a first
shot at a patch. It seems to work without regressions so far, but I still need
to test it on other configurations.
(Assignee)

Comment 7

14 years ago
Confirming and taking.
Assignee: mkaply → smontagu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

14 years ago
Just to make it clear. I am not a developer or something, but i would like to
say that i am very proud you paid attention to this problem and might have
solved it. By the way, I am using now Mozilla 1.4 on an hebrew Win98SE and the
situation is much better. The text is written correctly and connected, the
justification is 90 % all right. I don't know if it is the SE or the 1.4. I will
check it shortly on another computer with an hebrew Win98 (not SE) and give you
an answer.
(Assignee)

Comment 9

14 years ago
I don't think that SE would make the difference: my own testing environment was
Hebrew-enabled SE. If you have a newer version of IE installed on your system,
we might be picking up the Arabic support from Uniscribe.

That implies that an even smaller number of users are affected by the bug than I
had thought in the first place, and I doubt if we want to add another boolean
flag with getter and setter to nsIPresContext to solve a very marginal bug. On
the other hand, replacing all those boolean flags by an array of state bits with
inlined setters and getters à la nsIFrame could be an all-round improvement. I
will file a new bug for that and make this depend on it.
(Assignee)

Updated

14 years ago
Depends on: 226778
(Reporter)

Comment 10

14 years ago
I have the final results
With Mozilla 1.2b on Win98 (not SE) it was not good.
However, I donwloaded Mozilla 1.5 on the same computer and IT WORKED. I don't
know what has been changed since 1.2b BUT IT SOLVED THE PROBLEM
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

14 years ago
By the way. I am sorry if your working for patch was for nothing. I am not
familiar with Mozilla's scrpiting or programming, and I dont much understand
what the patch does except solving the problem which was eventually solved
somehow (Allah knows) without it. 
I visited www.alquds.com www.arabynet.com www.arabia.com www.alqamoos.com
and it is fine.

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.