Closed Bug 1666713 Opened 2 years ago Closed 1 year ago

SeaMonkey 2.53.x source release contains generated binary files

Categories

(SeaMonkey :: Release Engineering, defect)

SeaMonkey 2.53 Branch
defect

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: psychonaut, Assigned: iannbugzilla)

References

()

Details

(Whiteboard: SM2.53.6)

Attachments

(1 file)

The SeaMonkey 2.53.4 source release tarball at https://archive.mozilla.org/pub/seamonkey/releases/2.53.4/source/seamonkey-2.53.4.source.tar.xz contains a number of generated files that probably shouldn't be there:

mozilla/third_party/python/psutil/build/lib.linux-x86_64-2.7/
mozilla/third_party/python/psutil/build/lib.linux-x86_64-2.7/psutil/
mozilla/third_party/python/psutil/build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so
mozilla/third_party/python/psutil/build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so
mozilla/third_party/python/psutil/build/temp.linux-x86_64-2.7/
mozilla/third_party/python/psutil/build/temp.linux-x86_64-2.7/psutil/
mozilla/third_party/python/psutil/build/temp.linux-x86_64-2.7/psutil/_psutil_common.o
mozilla/third_party/python/psutil/build/temp.linux-x86_64-2.7/psutil/_psutil_linux.o
mozilla/third_party/python/psutil/build/temp.linux-x86_64-2.7/psutil/_psutil_posix.o
mozilla/third_party/python/psutil/psutil/_psutil_linux.so
mozilla/third_party/python/psutil/psutil/psutil_posix.so
mozilla/third_party/python/psutil/tmp/tmp12gn5X.o
mozilla/third_party/python/psutil/tmp/tmp1rp_Y8.o
mozilla/third_party/python/psutil/tmp/tmp2AQM6Z.o
mozilla/third_party/python/psutil/tmp/tmp2uKxMv.o
mozilla/third_party/python/psutil/tmp/tmp47RnvV.o
mozilla/third_party/python/psutil/tmp/tmp4IqNnV.o
mozilla/third_party/python/psutil/tmp/tmp53SV8M.o
mozilla/third_party/python/psutil/tmp/tmp5V_A6J.o
mozilla/third_party/python/psutil/tmp/tmp7bWLwo.o
mozilla/third_party/python/psutil/tmp/tmp8jgDur.o
mozilla/third_party/python/psutil/tmp/tmp8OgbXp.o
mozilla/third_party/python/psutil/tmp/tmp91s1py.o
mozilla/third_party/python/psutil/tmp/tmpAnI_Ug.o
mozilla/third_party/python/psutil/tmp/tmp_AVqg7.o
mozilla/third_party/python/psutil/tmp/tmpBFcM2M.o
mozilla/third_party/python/psutil/tmp/tmpblnaVS.o
mozilla/third_party/python/psutil/tmp/tmpC0sNFr.o
mozilla/third_party/python/psutil/tmp/tmpc374uv.o
mozilla/third_party/python/psutil/tmp/tmpC5EPo7.o
mozilla/third_party/python/psutil/tmp/tmpCfTkNO.o
mozilla/third_party/python/psutil/tmp/tmpChVbet.o
mozilla/third_party/python/psutil/tmp/tmpcq9X1d.o
mozilla/third_party/python/psutil/tmp/tmpCU5xYn.o
mozilla/third_party/python/psutil/tmp/tmpD1IIog.o
mozilla/third_party/python/psutil/tmp/tmpDLE54G.o
mozilla/third_party/python/psutil/tmp/tmpewiacF.o
mozilla/third_party/python/psutil/tmp/tmpgIfClk.o
mozilla/third_party/python/psutil/tmp/tmphKD_rk.o
mozilla/third_party/python/psutil/tmp/tmpHtu9Cy.o
mozilla/third_party/python/psutil/tmp/tmpiait6V.o
mozilla/third_party/python/psutil/tmp/tmpIZZhqE.o
mozilla/third_party/python/psutil/tmp/tmpja4r1P.o
mozilla/third_party/python/psutil/tmp/tmpjdGybu.o
mozilla/third_party/python/psutil/tmp/tmpm88GvX.o
mozilla/third_party/python/psutil/tmp/tmp_m8C5t.o
mozilla/third_party/python/psutil/tmp/tmpma0f3y.o
mozilla/third_party/python/psutil/tmp/tmpn_9Unu.o
mozilla/third_party/python/psutil/tmp/tmpNxVm0n.o
mozilla/third_party/python/psutil/tmp/tmpQhjiKC.o
mozilla/third_party/python/psutil/tmp/tmpqxXrtM.o
mozilla/third_party/python/psutil/tmp/tmpRH6Tfl.o
mozilla/third_party/python/psutil/tmp/tmpRNGren.o
mozilla/third_party/python/psutil/tmp/tmp_Selwg.o
mozilla/third_party/python/psutil/tmp/tmpSZcPso.o
mozilla/third_party/python/psutil/tmp/tmptLnqJr.o
mozilla/third_party/python/psutil/tmp/tmpuUlk6H.o
mozilla/third_party/python/psutil/tmp/tmpVz1WzA.o
mozilla/third_party/python/psutil/tmp/tmpwBMa6C.o
mozilla/third_party/python/psutil/tmp/tmpWeVq4U.o
mozilla/third_party/python/psutil/tmp/tmpxlHTCF.o
mozilla/third_party/python/psutil/tmp/tmpXnflIe.o
mozilla/third_party/python/psutil/tmp/tmpZWRUo
.o
mozilla/third_party/python/psutil/tmp/tmpzyA3C8.o

Assignee: nobody → iann_bugzilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: SeaMonkey 2.53.4 source release contains generated binary files → SeaMonkey 2.53.x source release contains generated binary files

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: Source tarball contains generated binary files
Testing completed (on m-c, etc.): 2.53.6
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Only needed for release branches.

Attachment #9197826 - Flags: review?(frgrahl)
Attachment #9197826 - Flags: approval-comm-release?
Attachment #9197826 - Flags: approval-comm-esr60?

Comment on attachment 9197826 [details] [diff] [review]
1666713-tarball-2536.patch

LGTM

Attachment #9197826 - Flags: review?(frgrahl)
Attachment #9197826 - Flags: review+
Attachment #9197826 - Flags: approval-comm-release?
Attachment #9197826 - Flags: approval-comm-release+
Attachment #9197826 - Flags: approval-comm-esr60?
Attachment #9197826 - Flags: approval-comm-esr60+
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.