Closed Bug 1666897 Opened 2 years ago Closed 2 years ago

Allow execution via |python -m mozphab ...|

Categories

(Conduit :: moz-phab, enhancement)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mhentges, Assigned: mhentges)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Programmatically finding the moz-phab entry point is not easy and depends on pip output that may change in future versions.
By making python -m mozphab ... possible, programmatic execution of moz-phab will be simplified.

Assignee: nobody → mhentges
Status: NEW → ASSIGNED
Duplicate of this bug: 1667137
Blocks: 1666896

Adds the __main__.py file so that python -m mozphab has an entry
point to use.

Adds the __main__.py file so that python -m mozphab has an entry
point to use.

Attachment #9178279 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.