Remove Messages column in Subscribe.

VERIFIED FIXED in mozilla1.2alpha

Status

SeaMonkey
MailNews: Message Display
P4
minor
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Assigned: stephend@netscape.com (gone - use stephen.donner@gmail.com instead))

Tracking

Trunk
mozilla1.2alpha

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 4 obsolete attachments)

Build ID: 2002-09-04-08, All OSs.

Summary: Remove Messages column in Subscribe.

Per the spec, we currently have the Messages column in Subscribe for News.

The problem is, it doesn't do anything, and isn't planned for implementation
anytime soon (correct me if I'm wrong).

I've got a patch to rip it out.
Keywords: nsbeta1, patch, review, ui
Priority: -- → P4

Comment 4

16 years ago
If it doesn't do anything, yes, please remove it. If there is any chance it 
might get implemented in the future, please file a separate bug so it can be 
tracked. Thanks. 
you are right.

news gets no love, and won't for a while.

can you comment out the xul instead of removing it, refer to a new bug (or find
the existing bug) for "implement message count in subscribe"?

I think you should remove this splitter as well:

             <splitter class="tree-splitter"/>
-            <treecol id="messagesColumn" persist="hidden"
label="&messagesHeader.label;"
-                     sort="?TotalMessages"/>
Created attachment 97844 [details] [diff] [review]
Fix, addresses Seth's comments.

Removes extraneous splitter, comments out code instead of removing it.
Attachment #97835 - Attachment is obsolete: true
Created attachment 97845 [details] [diff] [review]
Patch, 'final' version.  It helps to attach the correct patch.

Sorry, this really is it.
Attachment #97844 - Attachment is obsolete: true
The bug for implementing message counts is bug 38906.  Do we want that in the
comments of Subscribe.xul/Subscribe.dtd?
Status: NEW → ASSIGNED
Created attachment 97848 [details] [diff] [review]
Yet Another Patch.  Comments out the Search view's splitter, too.
Attachment #97845 - Attachment is obsolete: true
Created attachment 97850 [details] [diff] [review]
Should be final, was tested on Classic/Modern, tree and flat view of Subscribe.
Attachment #97848 - Attachment is obsolete: true

Comment 11

16 years ago
Comment on attachment 97850 [details] [diff] [review]
Should be final, was tested on Classic/Modern, tree and flat view of Subscribe.

r=varga
Attachment #97850 - Flags: review+
Comment on attachment 97850 [details] [diff] [review]
Should be final, was tested on Classic/Modern, tree and flat view of Subscribe.

sr=sspitzer

affects end users positively, has UI approval from jglick.

thanks for cleaning up my mess, hammer.
Attachment #97850 - Flags: superreview+

Comment 13

16 years ago
Comment on attachment 97850 [details] [diff] [review]
Should be final, was tested on Classic/Modern, tree and flat view of Subscribe.

a=asa (on behalf of drivers) for checkin to 1.2a
Attachment #97850 - Flags: approval+
Fix landed on the trunk.  Thanks to all!  QA over to Karen, because I won't QA
my own fixes.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
QA Contact: stephend → huang
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.2alpha
QA Contact: huang → yulian
Can't verify my own bugs --> gary
QA Contact: yulian → gchan

Comment 16

15 years ago
Using trunk build 20030218 on winxp, maco osx and linux this is fixed. Verified. 
Status: RESOLVED → VERIFIED

Updated

15 years ago
QA Contact: gchan → esther
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: esther → search
You need to log in before you can comment on or make changes to this bug.