scrollbars appear, even when content clipped to view window.

RESOLVED DUPLICATE of bug 45597

Status

()

RESOLVED DUPLICATE of bug 45597
17 years ago
17 years ago

People

(Reporter: bclough, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

On the page http://www.banksofthesusquehanna.com/Tests/index.html there's a
javascript text scroller.  This scroller uses an object to display the text, and
another object to clip the text to the screen.  The text object is a child of
the container object, which is in turn a child of the document.  

When the scrolling begins, the text object is positioned to the right of the
screen, then it moves to the left.  

The portion of the text outside the container is invisible, as expected, but
there's still a scroll bar, sized as if the text object were totally visible.

As the text scrolls left accross the page, the scrollbar "thumb" grows,
indicating a decrease in the scrollable width of the document.  When the right
end of the text object enters the screen, the scrollbar disappears completely.

scrollbars shoudn't appear when any "decendant" object is outside the viewable
area of the browser window, only when visible content is outside.

Neither Netscape 4.79 nor IE 5.5 show a scrollbar when dispalying this page.

Reproducible: Always

Steps to Reproduce:
1. go to the example URL
Actual Results:  
Horizontal scrollbar appeared even though all fisible content was confined to
the viewable area of the browser.

Expected Results:  
The page should display without a horizontal scrollbar.

*** This bug has been marked as a duplicate of 45597 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.