Closed Bug 1667033 Opened 3 years ago Closed 2 years ago

firefox in "site specific" app (ssb) mode cannot open the unknown content type dialog ("what do you want to do with this file") so can't download files

Categories

(Firefox :: File Handling, defect, P3)

80 Branch
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: sergio.callegari, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

The "website as an app" or "site specific mode" is quite nice, but has an issue in that it cannot produce "file save" dialogs.

I am using "whatsapp web" as an app in firefox. Everything is OK, but when I try to download a picture that has been sent to me nothing happens. In regular mode, firefox opens a file dialog letting me open the image with an application or save it.

Issue is seen on linux, but may be cross-platform.

Actual results:

When I try to download a file from a website running in app mode in firefox nothing happens and the operation is silently ignored.

Expected results:

Firefox should open a file dialog letting me open the file with an application or save it to disk (as it does when not running in site specific mode).

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → File Handling
Blocks: ssb
Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Summary: firefox in "site specific" app mode cannot open file save dialogs → firefox in "site specific" app (ssb) mode cannot open the unknown content type dialog ("what do you want to do with this file") so can't download files

Closing per bug 1682593.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX

I agree that it is better not to have a feature than to have it permanently broken. However I understand that the feature that is going away here is the whole "Sites in app mode" one. Is this the case?

If so, this is very untimely, IMHO. Whatever previous research has shown, the pandemic is causing lots of web apps to appear to support remote working and education and most of these are meant to be used as if they were regular system applications, with no browser interface. This is not just for aesthetic, but also because inadvertently acting on the browser interface (and particularly on the back/forward buttons, rather than the app provided buttons) may break the application. Yes, it may be bad app design, but it is not likely to change.

You need to log in before you can comment on or make changes to this bug.