Closed Bug 1667173 Opened 9 months ago Closed 9 months ago

Recipient container grows horizontally when multiple addresses are dropped from the Contacts sidebar

Categories

(Thunderbird :: Message Compose Window, defect, P1)

Tracking

(thunderbird_esr78+ fixed, thunderbird82 fixed)

RESOLVED FIXED
83 Branch
Tracking Status
thunderbird_esr78 + fixed
thunderbird82 --- fixed

People

(Reporter: aleca, Assigned: aleca)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Bug 1663057 introduced a regression that causes the input field to grow in size when addresses are dropped from the Contacts sidebar, resulting in a broken UI with an unwanted horizontal overflow.

Prevent the growth of the input field if the drop comes from the Address Book.

Attachment #9177705 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9177705 [details] [diff] [review]
1667173-recipients-area-growth.diff

Review of attachment 9177705 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/base/content/mailWidgets.js
@@ +2212,5 @@
>        });
>  
>        this.addEventListener("drop", event => {
>          if (!event.dataTransfer.getData("text/pills")) {
> +          // Interrupt if dealing with addresses coming from the Contacts sidebar

nit: . at end.

But isn't it only the setting of size you want to skip, so I'm not sure the check is in the right place?

But isn't it only the setting of size you want to skip, so I'm not sure the check is in the right place?

If the addresses are coming from the sidebar we don't need to update the size of the input field as we don't need to accommodate strings since those addresses will be immediately added as pills.
The size check is only if pure text gets dropped in the input field, which needs to grow to accommodate the full text.

Blocks: 1666463

Comment updated.

Attachment #9177705 - Attachment is obsolete: true
Attachment #9177705 - Flags: review?(mkmelin+mozilla)
Attachment #9177735 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9177735 [details] [diff] [review]
1667173-recipients-area-growth.diff

Review of attachment 9177735 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks! I'll clarify the comment a bit more and land it.
Attachment #9177735 - Flags: review?(mkmelin+mozilla) → review+

(78 will be affected once bug 1663057 goes to 78)

Target Milestone: --- → 83 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/7c155c1b1aaf
Fix recipients area growing horizontally when addresses are dragged and dropped from the Contacts sidebar. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Depends on: 1667602
No longer depends on: 1667602
See Also: → 1667602

Comment on attachment 9177735 [details] [diff] [review]
1667173-recipients-area-growth.diff

[Approval Request Comment]
Pills polish.

Attachment #9177735 - Flags: approval-comm-esr78?
Attachment #9177735 - Flags: approval-comm-beta?

Comment on attachment 9177735 [details] [diff] [review]
1667173-recipients-area-growth.diff

[Triage Comment]
Approved for beta

Attachment #9177735 - Flags: approval-comm-beta? → approval-comm-beta+

Looks good to me testing the 82.0b3 release candidate on Ubuntu 18.04 LTS.

Comment on attachment 9177735 [details] [diff] [review]
1667173-recipients-area-growth.diff

[Triage Comment]
Approved for esr78

Attachment #9177735 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.