after composing a mail and clicking send (or replying) the message appears to send and returns no errors but the mail never arrives at the other end (error handling problem)

RESOLVED WORKSFORME

Status

MailNews Core
Networking: SMTP
--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: James Carr, Assigned: Scott MacGregor)

Tracking

({qawanted})

Trunk
x86
Windows XP
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

The message gets copied okay to the Sent folder in Local Folders. It just never
arrives at the actual destination.

I have about 5 accounts setup in netscape mail, including different servers, I
have tried sending with them all, I have tried sending to many different e-mails
(including myself) (including different web mail systems). As far as I can track
down this started to happen as soon as I upgraded to the final 1.1 release.
Before this I was using 1.1alpha. 

I have had problems with mozilla mail before, so I have had to manually edit the
prefs.js file because it used to just completely forget all my settings and mail
accounts, so a lot of the time i had to manually recreate all of the mail
accounts in prefs.js and set the file locations in them. i now keep a backup
copy of prefs.js and reinstate this whenever something goes wrong

Reproducible: Always

Steps to Reproduce:
1.compose or reply to a mail
2.click send
3.watch the send dialog come up and then go away, as if mail was sent fine

Actual Results:  
the mail never arrives at destination, suspect never being sent at all

Expected Results:  
mail should have arrived

Comment 1

16 years ago
Did you install 1.1 into a new directory, or on top of an old installation.  You
should install 1.1 into a clean directory. 

This is not the correct component for this bug, probably "Networking: MailNews
General" or "Mail Window Front End".

When you hit "send" does mozilla access the network at all?
(Reporter)

Comment 2

16 years ago
Yes, It is installed into a new directory, mozilla/mozilla , the old one is
still there as mozilla.org/mozilla . yes looking at the network connection
status icon it sends and then receives a bit of information

i fail to see how this applies to the front end category or the general category
as this is a problem with sending mail only

Comment 3

16 years ago
Timothy, in comment #2 you indicate you ran into bug 155080 (user using Quick
Launch and single profile on Windows can lose their Mail account settings) and
had to edit your prefs.js file manually to get them back.  It is possible that
your editing of the prefs.js file did not restore the prefs.js file to the same
state as before you lost the settings and this is causing the problem.  I'm
sorry you ran into the bug, but to check this out could I ask you to create a
new profile and add one of those accounts to that profile and then try your
steps to reproduce.  I expect this will work ok.  If so, you will have to create
a new profile and then copy your local mail folders, personal address book and
collected address book into that new prolfile.  I will email the steps for you
to do this. 
(Reporter)

Comment 4

16 years ago
I've tried your steps exactly as you e-mailed no luck im afraid!
(Reporter)

Comment 5

16 years ago
still not able to send any e-mail. i'm gonna move to outlook express.
The bug happens due to lack of error handling. if SMTP opens connection and
immediately closes it (without any response) - Mozilla is unable to recognize
this situation.

I have run into this issue several times until I've got the idea what happens. I
think I have submitted other bug concerning this issue, but I don't seem to find it.

This is critical and in order to avoid loss I'm using different mail client.

Comment 7

16 years ago
Could somebody please post an SMTP log showing how our handling error handling
is incorrect?
Blocks: 193931
Keywords: qawanted

Comment 8

16 years ago
Reporter, please attach an SMTP log of this problem. Directions for creating one
are here:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
Summary: after composing a mail and clicking send (or replying) the message appears to send and returns no errors but the mail never arrives at the other end → after composing a mail and clicking send (or replying) the message appears to send and returns no errors but the mail never arrives at the other end (error handling problem)
(Reporter)

Comment 9

16 years ago
i downloaded the nightly yesterday (b2003021808) and can no longer reproduce
this error. the profile etc are the same since this bug was originally entered.

Comment 10

16 years ago
That's good news. Thanks for following up. Resolving worksforme.
No longer blocks: 193931
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.