Closed Bug 1667483 Opened 4 years ago Closed 4 years ago

Use newer clangd by default (currently using 10.0.0)

Categories

(Developer Infrastructure :: Developer Environment Integration, task)

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1666550

People

(Reporter: mstange, Unassigned)

References

(Blocks 1 open bug)

Details

It seems that we currently have two different versions of clangd in .mozbuild, installed by mach bootstrap, at least on macOS:

  • ~/.mozbuild/clang-tools/clang-tidy/bin/clangd has version 10.0.0
  • ~/.mozbuild/clang/bin/clangd has version 11.0.0

mach ide vscode produces a settings.json which uses the former, older version.
Can we switch it to use the newer version instead? Or maybe update clang-tidy? Or maybe even remove the duplication?

I was encountering crashes during background indexing with the older version.

I have now changed my settings.json manually to point to ~/.mozbuild/clang/bin/clangd.
As an unexpected side-effect, I can now see background indexing progress in the VSCode status bar! (It currently says "🔁 indexing: 288/8706".)

Yeah, it is planed, see bug 1666550

Seems to just be a duplicate of that bug, please re-open if I'm interpreting the request wrong.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE

Sounds good to me.

Product: Firefox Build System → Developer Infrastructure
You need to log in before you can comment on or make changes to this bug.