mozilla crashes with http://www.greenwichmeantime.com

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: Fred Wong, Assigned: Joe Chou)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
First of all, this bug is probably related to bug# 166808. The browser crashes
when accessing http://www.greenwichmeantime.com and gives the following message:


INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory
Gdk-ERROR **: Fatal IO error 9 (Bad file descriptor) on X server :0.0.
INTERNAL ERROR on Browser End: Could not read ack from browser
System error?:: Resource temporarily unavailable
*** Bug 166813 has been marked as a duplicate of this bug. ***
oji
Assignee: asa → joe.chou
Severity: normal → critical
Component: Browser-General → OJI
Keywords: crash
QA Contact: asa → pmac

Comment 3

16 years ago
Worksforme in Mozilla 1.1 (release 20020826) on Windows NT

Comment 4

16 years ago
do you still crash when upgrading to JRE 1.4.x ?

Comment 5

16 years ago
Reporter: what BuildID and JRE versions are you using?

WFM using BuildID 2002083005 and JRE 1.4.0_01-b03 on Linux (RH7.3)
(Assignee)

Comment 6

16 years ago
WFM with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417, and
JRE 1.4.0.

Mark WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
Hi everyone,

I(reporter of the bug) think I have found out the culprit. There was another
copy of java plugin in the plugins directory: javaplugin_oji.so, which I suppose
created some sort of conflict with one provided by the JRE 1.4.x plugin package,
i.e. libjavaplugin_oji.so. I don't know whether it has always been there or not.
But once I removed it(javaplugin_oji.so) the browser does not crash anymore. So,
sorry for all the anxieties caused by me ;-). However, I discovered one other
thing with the same site which you might be intrested in investigating. The
clock Java Applet works for the main site but if I select a country to find out
its time, the Applet reports the following error:
"lang:ClassNotFoundException:...". Do you think that's the problem with the site
or the plugin?

Thank you very much
Fred
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 8

16 years ago
Really you should have left this bug closed and logged a new one on this problem.

Bug 167466 now covers this subsequent problem, resolving this one again as WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: joe.chou → petersen
fixing small error for pmac@netscape.com (filter with : SPAMMAILSUCKS)
Assignee: petersen → joe.chou
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.