Closed Bug 1668248 Opened 1 year ago Closed 1 year ago

Check string type max capacity before attempting to adopt memory in `nsDOMDataChannel::Send`

Categories

(Core :: WebRTC: Networking, defect, P1)

defect

Tracking

()

RESOLVED FIXED
83 Branch
Tracking Status
firefox83 --- fixed

People

(Reporter: padenot, Assigned: padenot)

References

Details

Crash Data

Attachments

(3 files)

Strings can have less capacity than arraybuffers, depending on the type.

Assignee: nobody → padenot
Status: NEW → ASSIGNED

Apologies for the tweet but I filed that three years ago, so I figured that's okay to post...
https://bugzilla.mozilla.org/show_bug.cgi?id=1382779

Duplicate of this bug: 1382779
Crash Signature: [@ nsDOMDataChannel::Send]
Pushed by padenot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eaa857f4564d
Use fallible string operations in nsDOMDataChannel::Send. r=bwc
https://hg.mozilla.org/integration/autoland/rev/9f6b8aa11110
Use fallible string operations in WebSocket::Send. r=valentin
https://hg.mozilla.org/integration/autoland/rev/3097e934187b
Test that DataChannel.send fails gracefully when the argument is too big. r=bwc
Flags: needinfo?(padenot)
Pushed by padenot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6f557d78a36d
Use fallible string operations in nsDOMDataChannel::Send. r=bwc
https://hg.mozilla.org/integration/autoland/rev/fc35315d5e8e
Use fallible string operations in WebSocket::Send. r=valentin
https://hg.mozilla.org/integration/autoland/rev/cf7ae63672c8
Test that DataChannel.send fails gracefully when the argument is too big. r=bwc
Severity: -- → S2
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
You need to log in before you can comment on or make changes to this bug.