Closed Bug 1668490 Opened 1 year ago Closed 1 year ago

Intermittent toolkit/components/messaging-system/test/browser/browser_remotesettings_experiment_enroll.js | Test timed out -

Categories

(Firefox :: Messaging System, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr78 --- unaffected
firefox81 --- unaffected
firefox82 --- unaffected
firefox83 --- unaffected

People

(Reporter: intermittent-bug-filer, Assigned: andreio)

Details

(Keywords: intermittent-failure, regression)

Filed by: btara [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=317227855&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/BDTdwichQtmRwTmXIRv8hA/runs/0/artifacts/public/logs/live_backing.log
Reftest URL: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/BDTdwichQtmRwTmXIRv8hA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1


[task 2020-10-01T00:33:33.156Z] 00:33:33 INFO - TEST-START | toolkit/components/messaging-system/test/browser/browser_remotesettings_experiment_enroll.js
[task 2020-10-01T00:33:33.157Z] 00:33:33 INFO - GECKO(11580) | Chrome file doesn't exist: Z:\task_1601510791\build\tests\mochitest\browser\toolkit\components\messaging-system\test\browser\head.js
[task 2020-10-01T00:33:33.176Z] 00:33:33 INFO - GECKO(11580) | console.debug: RSLoader:
[task 2020-10-01T00:33:33.176Z] 00:33:33 INFO - GECKO(11580) | Updating recipes with trigger mochitest
[task 2020-10-01T00:33:33.177Z] 00:33:33 INFO - GECKO(11580) | console.debug: RSLoader:
[task 2020-10-01T00:33:33.177Z] 00:33:33 INFO - GECKO(11580) | Got 1 recipes from Remote Settings
[task 2020-10-01T00:33:33.177Z] 00:33:33 INFO - GECKO(11580) | console.debug: RSLoader:
[task 2020-10-01T00:33:33.179Z] 00:33:33 INFO - GECKO(11580) | No targeting for recipe, so it matches automatically
[task 2020-10-01T00:33:33.179Z] 00:33:33 INFO - GECKO(11580) | console.debug: RSLoader:
[task 2020-10-01T00:33:33.179Z] 00:33:33 INFO - GECKO(11580) | 4be1b724-397f-44e1-81e5-48862e9de248 matched
[task 2020-10-01T00:33:33.179Z] 00:33:33 INFO - GECKO(11580) | console.debug: ExperimentManager:
[task 2020-10-01T00:33:33.179Z] 00:33:33 INFO - GECKO(11580) | Enrollment foo has expired, aborting.
[task 2020-10-01T00:33:33.179Z] 00:33:33 INFO - GECKO(11580) | console.debug: RSLoader:
[task 2020-10-01T00:33:33.179Z] 00:33:33 INFO - GECKO(11580) | 1 recipes matched. Finalizing ExperimentManager.
[task 2020-10-01T00:33:36.515Z] 00:33:36 INFO - GECKO(11580) | [Parent 7776: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0000018E8E626400 == 6 [pid = 7776] [id = 6] [url = about:blank]
[task 2020-10-01T00:33:36.515Z] 00:33:36 INFO - GECKO(11580) | [Parent 7776: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0000018E8D795C00 == 5 [pid = 7776] [id = 5] [url = about:blank]
[task 2020-10-01T00:33:36.728Z] 00:33:36 INFO - GECKO(11580) | [Parent 7776: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 16 (0000018E886EE430) [pid = 7776] [serial = 1] [outer = 0000000000000000] [url = chrome://gfxsanity/content/sanityparent.html]
[task 2020-10-01T00:33:36.728Z] 00:33:36 INFO - GECKO(11580) | [Parent 7776: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 15 (0000018EFF3FA7D0) [pid = 7776] [serial = 12] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:36.728Z] 00:33:36 INFO - GECKO(11580) | [Parent 7776: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 14 (0000018EFF3FD6F0) [pid = 7776] [serial = 13] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:38.004Z] 00:33:38 INFO - GECKO(11580) | [Child 12224: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 000001BD8EBA1800 == 1 [pid = 12224] [id = 0] [url = about:blank]
[task 2020-10-01T00:33:39.290Z] 00:33:39 INFO - GECKO(11580) | [Child 8904: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 000001BEC53A4C00 == 1 [pid = 8904] [id = 0] [url = chrome://gfxsanity/content/sanitytest.html]
[task 2020-10-01T00:33:39.290Z] 00:33:39 INFO - GECKO(11580) | [Child 8904: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 000001BEC575F800 == 0 [pid = 8904] [id = 1] [url = about:blank]
[task 2020-10-01T00:33:40.816Z] 00:33:40 INFO - GECKO(11580) | [Parent 7776: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 13 (0000018E886CAC00) [pid = 7776] [serial = 2] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:40.816Z] 00:33:40 INFO - GECKO(11580) | [Parent 7776: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 12 (0000018E9294E800) [pid = 7776] [serial = 15] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:40.816Z] 00:33:40 INFO - GECKO(11580) | [Parent 7776: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 11 (0000018E8E62C000) [pid = 7776] [serial = 14] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:40.816Z] 00:33:40 INFO - GECKO(11580) | [Parent 7776: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 10 (0000018E8D65EC00) [pid = 7776] [serial = 10] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:42.110Z] 00:33:42 INFO - GECKO(11580) | [Child 12224: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 5 (000001BD8EBA7000) [pid = 12224] [serial = 2] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:42.129Z] 00:33:42 INFO - GECKO(11580) | [Child 12224: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 4 (000001BD8F610090) [pid = 12224] [serial = 1] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:43.386Z] 00:33:43 INFO - GECKO(11580) | [Child 8904: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 4 (000001BEC53AA400) [pid = 8904] [serial = 2] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:43.404Z] 00:33:43 INFO - GECKO(11580) | [Child 8904: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 3 (000001BEC571C0E0) [pid = 8904] [serial = 4] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:43.404Z] 00:33:43 INFO - GECKO(11580) | [Child 8904: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 2 (000001BEC571B090) [pid = 8904] [serial = 1] [outer = 0000000000000000] [url = chrome://gfxsanity/content/sanitytest.html]
[task 2020-10-01T00:33:43.849Z] 00:33:43 INFO - GECKO(11580) | [Child 3140: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 11 (0000026A7DE9A000) [pid = 3140] [serial = 8] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:43.849Z] 00:33:43 INFO - GECKO(11580) | [Child 3140: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 10 (0000026A7DE97800) [pid = 3140] [serial = 6] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:43.849Z] 00:33:43 INFO - GECKO(11580) | [Child 3140: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 9 (0000026A7DE96000) [pid = 3140] [serial = 4] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:43.849Z] 00:33:43 INFO - GECKO(11580) | [Child 3140: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 8 (0000026A7DAE0400) [pid = 3140] [serial = 2] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:43.898Z] 00:33:43 INFO - GECKO(11580) | [Child 3140: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 7 (0000026A7DE4F9A0) [pid = 3140] [serial = 3] [outer = 0000000000000000] [url = moz-extension://5e664c5e-5410-4896-96ed-57665ccb757e/_generated_background_page.html]
[task 2020-10-01T00:33:43.898Z] 00:33:43 INFO - GECKO(11580) | [Child 3140: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0000026A7DE95000 == 3 [pid = 3140] [id = 1] [url = moz-extension://5e664c5e-5410-4896-96ed-57665ccb757e/_generated_background_page.html]
[task 2020-10-01T00:33:44.163Z] 00:33:44 INFO - GECKO(11580) | [Child 7428: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 2 (000001BF6F04D400) [pid = 7428] [serial = 2] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:46.170Z] 00:33:46 INFO - GECKO(11580) | [Child 12224: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 3 (000001BD8879CC00) [pid = 12224] [serial = 3] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:46.170Z] 00:33:46 INFO - GECKO(11580) | [Child 12224: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 2 (000001BD8F659800) [pid = 12224] [serial = 4] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:47.449Z] 00:33:47 INFO - GECKO(11580) | [Child 8904: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 1 (000001BEC575E800) [pid = 8904] [serial = 3] [outer = 0000000000000000] [url = chrome://gfxsanity/content/sanitytest.html]
[task 2020-10-01T00:33:47.449Z] 00:33:47 INFO - GECKO(11580) | [Child 8904: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 0 (000001BEC5760800) [pid = 8904] [serial = 5] [outer = 0000000000000000] [url = about:blank]
[task 2020-10-01T00:33:47.945Z] 00:33:47 INFO - GECKO(11580) | [Child 3140: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 6 (0000026A7FA09800) [pid = 3140] [serial = 10] [outer = 0000000000000000] [url = moz-extension://5e664c5e-5410-4896-96ed-57665ccb757e/_generated_background_page.html]
[task 2020-10-01T00:35:03.161Z] 00:35:03 INFO - TEST-INFO | started process screenshot
[task 2020-10-01T00:35:03.220Z] 00:35:03 INFO - TEST-INFO | screenshot: exit 0
[task 2020-10-01T00:35:03.220Z] 00:35:03 INFO - Buffered messages logged at 00:33:33
[task 2020-10-01T00:35:03.220Z] 00:35:03 INFO - Entering test bound setup
[task 2020-10-01T00:35:03.220Z] 00:35:03 INFO - Leaving test bound setup
[task 2020-10-01T00:35:03.221Z] 00:35:03 INFO - Entering test bound test_experimentEnrollment
[task 2020-10-01T00:35:03.221Z] 00:35:03 INFO - Buffered messages finished
[task 2020-10-01T00:35:03.221Z] 00:35:03 INFO - TEST-UNEXPECTED-FAIL | toolkit/components/messaging-system/test/browser/browser_remotesettings_experiment_enroll.js | Test timed out -
[task 2020-10-01T00:35:03.221Z] 00:35:03 INFO - GECKO(11580) | MEMORY STAT | vsize 2104243MB | vsizeMaxContiguous 65436556MB | residentFast 258MB | heapAllocated 72MB
[task 2020-10-01T00:35:03.221Z] 00:35:03 INFO - TEST-OK | toolkit/components/messaging-system/test/browser/browser_remotesettings_experiment_enroll.js | took 90052ms

Component: Nimbus Desktop Client → Messaging System

The failures were caused by a version of this revision that was since backed out, it should be fixed now.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Undo, this should not be a regression the failure was caused by a patch that got backed out.

No longer regressed by: 1667791
Summary: Intermittent TV toolkit/components/messaging-system/test/browser/browser_remotesettings_experiment_enroll.js | Test timed out - → Intermittent toolkit/components/messaging-system/test/browser/browser_remotesettings_experiment_enroll.js | Test timed out -
Assignee: nobody → andrei.br92
You need to log in before you can comment on or make changes to this bug.