Background GIF image only appears on top of page

VERIFIED FIXED in M13

Status

()

P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: moshev, Assigned: pavlov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
When going to www.linux-mandrake.com/lothar,
There is a blue/striped backround on this page.
In NS 4.7 if you scroll down to the end of page, the
background is still there, using M10, the background
is only visible on the first visible part of the page,
if you scroll down, the rest of the background is black.

P.S. While loading,if the whole background is visible, but
	when loaded the bug could be seen.
P.P.S, two attachments coming...
(Reporter)

Comment 1

19 years ago
Created attachment 2249 [details]
NS 4.7, and OK
(Reporter)

Comment 2

19 years ago
Created attachment 2250 [details]
M10 - wrong

Updated

19 years ago
Assignee: don → pnunn
Component: Browser-General → ImageLib

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

19 years ago
Target Milestone: M11 → M12

Comment 3

19 years ago
Resetting QA contact from leger.

Updated

19 years ago
Assignee: pnunn → dcone
Status: ASSIGNED → NEW

Comment 4

19 years ago
dcone:
Is this yours? I can't remember who fixed the background
problem...
-pn

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 5

19 years ago
Took out a clipping call in nsCSSRendinging.cpp

Updated

19 years ago
Summary: Background is broken → Background GIF image only appears on top of page

Comment 6

19 years ago
Weird. Verified fixed on:
	- 1999120208 Mac OS Commercial
	- 1999120108 Win32 Mozilla

However, I'm still seeing this problem (or a related one) on 1999120311 Linux.
Holding until early next week to re-open.

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 7

19 years ago
Re-opening. Still occurs on 1999120708 Linux commercial build.

Updated

19 years ago
Resolution: FIXED → ---

Updated

19 years ago
Target Milestone: M12 → M13

Comment 8

19 years ago
Moving to m13 -- have a nice day.

Updated

19 years ago
Assignee: dcone → pavlov
Status: REOPENED → NEW

Comment 9

19 years ago
I am giving this to you so you can make these changes at 2137.

Uncomment the aRenderingContext.SetClipRect call, but use the tvrect instead.

It works on windows and Mac, see if this works on Linux and fixes your menu bug
we talked about yesterday.
Thanx -- Don
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 10

19 years ago
no more background on this page, but the page looks ok...
(Reporter)

Comment 11

19 years ago
The background is there and it looks ok today...
BTW, why is it resolved invalid?

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 12

19 years ago
Re-opening.

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: INVALID → FIXED

Comment 13

19 years ago
I'm guessing that Pavlov accidentally resolved it as Invalid because it's
directly below Fixed.

I'm re-resolving it as Fixed for verification.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 14

19 years ago
Confirmed fixed on NT 4.0 SP5, Mac OS 8.6 & RH Linux 6.0/GNOME using this
morning's M13 builds.
You need to log in before you can comment on or make changes to this bug.