MARQUEE LOOP attribute is ignored.

RESOLVED DUPLICATE of bug 160162

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 160162
16 years ago
13 years ago

People

(Reporter: Marek, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Consider the following example of a Marquee Tag:

<MARQUEE OnMouseOver="stop();" OnMouseOut="start();" 
OnFinish="location.replace('http://www.yahoo.com/');" 
WIDTH="100%" DIRECTION="left" BEHAVIOR="scroll"
LOOP="1">Message Here!</MARQUEE>

The LOOP=1 attribute should make the text scroll only once and then trigger the
OnFinish event (try it on IE6). The Loop attribute is ignored and hence the
OnFinish event is never triggered (if it is implemented at all, there is no way
to test it).

Just an additional comment, this is already reported elsewhere, the OnMouseOver
and OnMouseOut events work, but are unreliable. Fast mouse movements over the
MARQUEE may trigger the OnMouseOver event and not the OnMouseOut event, causing
the MARQUEE in this example to stop.

Comment 1

16 years ago
isn't this bug bug 159704 ?
(Reporter)

Comment 2

16 years ago
Bug 159704 talks about the Direction attribute having to be lowercase in order
to work. I'm reporting that the LOOP attribute, which uses a numeric value, is
ignored and the OnFinish event is not triggered.

Comment 3

16 years ago
Bug 159704 is about the attribute *value*, not the attribute name itself.

Comment 4

16 years ago
This is a duplicate of bug 160162 which was resolved as WONTFIX.
I suggest that you REOPEN that bug instead if you can provide some good 
arguments as to why LOOP is a good thing to support.
(There are two comments to that effect on bug 160162 already and it seems like
others have already fixed this...)

*** This bug has been marked as a duplicate of 160162 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.