Closed Bug 1668696 Opened 1 year ago Closed 1 year ago

Remove IS_IDENTITY flag from spatial nodes

Categories

(Core :: Graphics: WebRender, task)

task

Tracking

()

RESOLVED FIXED
83 Branch
Tracking Status
firefox83 --- fixed

People

(Reporter: gw, Assigned: gw)

References

Details

Attachments

(1 file)

No description provided.

This reverts a patch that added the IS_IDENTITY flag to spatial nodes.

This flag is not used yet, and was one of the patches identified as a
possible cause of a regression in one of the telemetry stats we track
for scene building (see bug 1667696). As such, it's easy to revert this
for now and see if it has an effect on those telemetry numbers.

--

Revert "Bug 1623792 - Pt 8 - Add IS_IDENTITY to spatial node flags. r=jnicol"

This reverts commit 771a48de769da1f2939b30ec18789ab28d577335.

Blocks: 1667696
Assignee: nobody → gwatson
Status: NEW → ASSIGNED
Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/37f1ed67727a
Remove IS_IDENTITY flag from spatial nodes. r=mattwoodrow
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch

Looks like this didn't have any effect on the telemetry results, and the patch backed out in bug 1667696. I think we can reland this if it's still useful.

You need to log in before you can comment on or make changes to this bug.