@ clicking on the submint-Button data will not transferred to $PHP_SELF, everey time

VERIFIED INVALID

Status

()

Core
Layout: Form Controls
--
major
VERIFIED INVALID
16 years ago
15 years ago

People

(Reporter: Markus Schwaab, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.0; Linux 2.4.18-4GB i686) Opera 6.0  [en]
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.1) Gecko/20020826

I have a database and made a Formular ( some input texts, 1 submit-button 
and 1 reset-button).
With <form action="<?print $PHP_SELF ?>" I read the submitted data into a 
variable. But the Variable never get the data.
I testet the same page with MS-IExplorer 5.5, Linux-Opera6.0 and Konqueror 
3.0.
It works with all of these Browsers.

Here the code for help:

--snip--
  <form method = "post" action = "<? print $PHP_SELF?>">
  <center>
  <table>
   <tr>
     <td> Anrede: </td>
     <td> <input type="text" name="anrede" size=25> </td>
   </tr>
   <tr>
     <td> Vorname: </td>
     <td> <input type="text" name="vorname" size=25> </td>
   </tr>
   <tr>
     <td> Nachname: </td>
     <td> <input type="text" name="nachname" size=25> </td>
   </tr>
   <tr>
     <td> Strasse: </td>
     <td> <input type="text" name="strasse" size=25> </td>
   </tr>
   <tr>
     <td> PLZ: </td>
     <td> <input type="text" name="plz" size=25> </td>
   </tr>
   <tr>
     <td> Ort: </td>
     <td> <input type="text" name="ort" size=25> </td>
   </tr>

   <tr>
     <td> <input type="submit" name="datenlos"> </td>
     <td align="right"> <input type="reset" value="L&ouml;schen"> </td>
   </tr>
  </table>
  </center>
 </form>

--snip--
I hope i could help

Reproducible: Always

Steps to Reproduce:
1.searched bug in my php code (some hours :-))but in comparison with other 
code it was correct
2.tryed the website with MS IExplorer 5.5 (Metaframe), Opera 6.0 and 
konqueror 3.0 




Expected Results:  
send the submitted data to $datenlos.

I work on SuSE 8.0 Professional with with self-installed mozilla downloaded 
from www.mozilla.org php is 4.1.0 and apache 1.3.23
Is there a publicly visible testcase?

If not, please attach the HTML the PHP outputs using
http://bugzilla.mozilla.org/attachment.cgi?bugid=166873&action=enter
(Reporter)

Comment 2

16 years ago
Created attachment 98117 [details]
The PHP-Script

This is the PHP/HTML-Code which causes the problem
(Reporter)

Comment 3

16 years ago
Created attachment 98118 [details]
Extended information about generated html-output and table-structure

Describes the content and structure of the table table where php should write
the data written in the Web-Formular.
Additional I appent the generated htmloutput from PHP
So the data should be posted to "/input_anschriften2_bugfixing.php"?
(Reporter)

Comment 5

16 years ago
Yes, after click submit php generate variables with the name of each input type.
value="name" become $name. The content of the input type become the content of
the variable $name.
$PHP_SELF sends data from the html area to the PHP area in the same document.
(Assignee)

Updated

16 years ago
Attachment #98117 - Attachment mime type: text/PHP → text/plain
(Assignee)

Comment 6

16 years ago
What happens if you remove the space between the quote (") and <? $PHP_SELF > ?
 The output you showed has an extra space.  It really shouldn't matter but I
don't see why else it would fail.

So the screen refreshes?  Try something else for me, change method="post" to
method="get" and tell me whether the URL in the URL bar changes.  If it does
change, could you please show what the URL looks like on Internet Explorer vs.
Mozilla?
(Reporter)

Comment 7

16 years ago
It`s crazy. I deleted all the spaces after "action =". Now it works !!!!
But then I undone deleting the spaces and it works anyhow.
I restarted my Workstation !.It worked anyhow.
Believe me. I don`t want to make a joke with you.

Greetings
             Markus
(Assignee)

Comment 8

15 years ago
Created attachment 108125 [details]
Testcase
(Assignee)

Comment 9

15 years ago
The above testcase shows the error I *thought* was happening, but evidently it
was not.  Markus, can you show us the outputted HTML before and after you made
that change?

Comment 10

15 years ago
Markus, are you still having a problem with this?

This report seems to be about a problem with PHP, not a problem with mozilla.
You understand that mozilla is dealing with the HTML output produced by the PHP
script. If you think mozilla is mishandling something, you need to provide the
HTML that mozilla is mishandling, not the PHP source code that produces the HTML.
(Reporter)

Comment 11

15 years ago
Ok, I think so too. It is a little bit crazy. I got the problem fixed when I 
was playing a little with my php options. The misterious thing is, that IE 5.5 
made no problems. 

Comment 12

15 years ago
Resolving based on the reporter's comment. Thanks for the update, Markus!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 13

15 years ago
Ok, thank you for your engagement bringing mozilla less of bugs. I will 
recommend mozilla to everyone I support with IT-Services as the browser of 
choice.

Status: RESOLVED → CLOSED
(Assignee)

Comment 14

15 years ago
reopening to mark verified
Status: CLOSED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Comment 15

15 years ago
invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
(Assignee)

Comment 16

15 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.