Open Bug 1669164 Opened 1 year ago Updated 8 months ago

[Win] Accessing about:welcome throws Error(s): no such table: top_sites

Categories

(Firefox :: Messaging System, defect, P2)

defect

Tracking

()

Iteration:
86.1 - Dec 14 - Dec 27
Tracking Status
firefox81 --- wontfix
firefox82 --- wontfix
firefox83 --- wontfix
firefox84 --- wontfix
firefox85 --- fix-optional
firefox86 --- affected

People

(Reporter: cfogel, Assigned: pdahiya)

References

(Blocks 1 open bug, )

Details

Attachments

(4 files)

Attached image topsites.png

Affected versions

  • 82.0b5, 82.0b7, 83.0a1(20201004212809)

Affected platforms

  • WIndows 10;

Steps to reproduce

  1. Launch Firefox, access about:welcome
  2. Open the Browser Console;
  3. Restart via CTRL+ALT+R key combination;

Expected result

  • no unexpected errors;

Actual result

  • following relevant errors listed:
  • Error(s) encountered during statement execution: no such table: top_sites 10 Sqlite.jsm:894
    ** handleCompletion resource://gre/modules/Sqlite.jsm:894
  • Failed to get importable top sites from chromium Error: Couldn't get rows from the Importable chromium top sites database. AboutWelcomeParent.jsm:85
    SearchService: init 2 SearchService.jsm:1312:16

Regression range

  • First bad: 2020-07-16;
  • Last good: 2020-07-17;
  • Pushlog: URL;
  • Potential regressor: mozregression points to bug 1649292;

Additional notes

  • attached screenshot with the issue;
  • S4 as suggested severity;
  • issue reproducible on only 1 machine our of 3 tested.
Has Regression Range: --- → yes
Has STR: --- → yes
Keywords: regression
Attached file 82.0b7.txt

Attached a console log output as well.

Moving to appropriate Component, as per regressor.

Component: Address Bar → Messaging System

As per :dao, this doesn't look related to the Remote Settings Top Sites, hence removing the blocking.

No longer blocks: 1653929, 1663147
Assignee: nobody → pdahiya
Severity: -- → S3
Iteration: --- → 83.2 - Oct 5 - Oct 18
Priority: -- → P1

Looking at logs the error originates from failing to import sites early in first run

https://searchfox.org/mozilla-central/source/browser/components/newtab/aboutwelcome/AboutWelcomeParent.jsm#86

NI @mardak for feedback if this is expected error in cases when db isn't ready and if there is a graceful way to handle it. Thanks

Flags: needinfo?(edilee)
Iteration: 83.2 - Oct 5 - Oct 18 → 84.1 - Oct 19 - Nov 01
Iteration: 84.1 - Oct 19 - Nov 01 → 84.2 - Nov 2 - Nov 15
Iteration: 84.2 - Nov 2 - Nov 15 → 85.1 - Nov 16 - Nov 29
Iteration: 85.1 - Nov 16 - Nov 29 → 85.2 - Nov 30 - Dec 13

This shouldn't be a regression as regressing bug is launching of multistage onboarding feature as default in Fx80 for the first time. As logged in #comment 4 the error happens when top_sites table during firstrun is not read in time and error is correctly captured in try catch block without breaking onboarding.

@cfogel I have tried to replicate this issue on Windows 10 but failed, will be great if you can check issue still exists/consistent and share some more info and steps to replicate. Thanks

Flags: needinfo?(cristian.fogel)
No longer regressed by: 1649292
Has Regression Range: yes → ---
Keywords: regression
Attached file about.txt

Double checked with 85.0a1 (2020-12-03)and the issue still appears on a fresh profile.
There is nothing else as far as STR goes from what I see.

Attaching the about:support data, in case there is something causing that jumps to eye.

Flags: needinfo?(cristian.fogel)

@cfogel Is the issue seen consistently or intermittent (reproducible in 1 out of 3 machine tested) as indicated in bug description? STR indicates you are using Ctrl+Alt+R to trigger restart on windows which doesn't seem to work for me. It will be extremely helpful if you can provide video recording of steps to follow. Thanks

Flags: needinfo?(cristian.fogel)
Attached image restart.gif

Attaching a recording with the issue. It's off my personal machine, and it reproduces 100% of the times.
Checked with 2 other machines in my home(different from the ones I confirmed the report on), but still not reproducible.

Flags: needinfo?(cristian.fogel)
Iteration: 85.2 - Nov 30 - Dec 13 → 86.1 - Jan 11 - Jan 24

(In reply to Cristian Fogel, QA [:cfogel] from comment #8)

Created attachment 9191554 [details]
restart.gif

Attaching a recording with the issue. It's off my personal machine, and it reproduces 100% of the times.
Checked with 2 other machines in my home(different from the ones I confirmed the report on), but still not reproducible.

@cfogel quick clarification on STR used to launch Firefox
a) Are you using command line to launch and restart Firefox?
b) Is the issue replicable when using GUI to launch, close and restart. Thanks!

Flags: needinfo?(cristian.fogel)

As far as normal usage, it's off Firefox.exe.
Same for starting the browser from the Mozregression GUI, if that is what you're referring to. Even with launching from mozregression the issue does not appear until triggering the restart from the keyboard shortcut.

Tried to start, or to set the page as default/homepage but this error is not displayed until the mentioned STR are done.

Flags: needinfo?(cristian.fogel)

Updating for 86.0a1(2020-01-03) build.

The error seems to indicate the chromium "Top Sites" database is missing the "top_sites" table in one of the profiles. We could add an extra check, e.g., SELECT COUNT(*) FROM sqlite_master WHERE name='top_sites' but we would probably still end up printing out an error as we would expect chrome to have created the table if it created the database.

I can create the issue on mac if I specially DROP TABLE top_sites; for a chrome profile

Flags: needinfo?(edilee)
You need to log in before you can comment on or make changes to this bug.