Closed Bug 1669413 Opened 7 months ago Closed 7 months ago

mach test is busted

Categories

(Testing :: General, defect, P1)

Default
defect

Tracking

(firefox-esr78 unaffected, firefox81 unaffected, firefox82 unaffected, firefox83 fixed)

RESOLVED FIXED
83 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox81 --- unaffected
firefox82 --- unaffected
firefox83 --- fixed

People

(Reporter: nchevobbe, Assigned: janerik)

References

(Blocks 1 open bug, Regression)

Details

Attachments

(1 file)

When trying to run ./mach test devtools/shared/resources/tests/browser_resources_getAllResources.js --headless

I get the following error:

Test configuration changed. Regenerating backend.
Error running mach:

    ['test', 'devtools/shared/resources/tests/browser_resources_getAllResources.js', '--headless', '--verify']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file test| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

BuildReaderError:
==============================
FATAL ERROR PROCESSING MOZBUILD FILE
==============================

The error occurred while processing the following file:

    /Users/nchevobbe/Projects/mozilla-central/toolkit/components/glean/metrics_index.py

This file was included as part of processing:

    /Users/nchevobbe/Projects/mozilla-central/toolkit/components/glean/moz.build

The underlying problem is a Python syntax error on line 0:

    None

Fix the syntax error and try again.


  File "/Users/nchevobbe/Projects/mozilla-central/testing/mach_commands.py", line 319, in test
    run_suites, run_tests = resolver.resolve_metadata(what)
  File "/Users/nchevobbe/Projects/mozilla-central/testing/mozbase/moztest/moztest/resolve.py", line 890, in resolve_metadata
    tests = list(self.resolve_tests(paths=[relpath]))
  File "/Users/nchevobbe/Projects/mozilla-central/testing/mozbase/moztest/moztest/resolve.py", line 857, in resolve_tests
    for test in self._resolve(**kwargs):
  File "/Users/nchevobbe/Projects/mozilla-central/testing/mozbase/moztest/moztest/resolve.py", line 638, in _resolve
    if (path in self.test_dirs or
  File "/Users/nchevobbe/Projects/mozilla-central/testing/mozbase/moztest/moztest/resolve.py", line 555, in test_dirs
    for test in self.tests:
  File "/Users/nchevobbe/Projects/mozilla-central/testing/mozbase/moztest/moztest/resolve.py", line 521, in tests
    for test in self.load_tests():
  File "/Users/nchevobbe/Projects/mozilla-central/testing/mozbase/moztest/moztest/resolve.py", line 402, in __call__
    gen_test_backend()
  File "/Users/nchevobbe/Projects/mozilla-central/python/mozbuild/mozbuild/gen_test_backend.py", line 50, in gen_test_backend
    backend.consume(data)
  File "/Users/nchevobbe/Projects/mozilla-central/python/mozbuild/mozbuild/backend/base.py", line 128, in consume
    for obj in objs:
  File "/Users/nchevobbe/Projects/mozilla-central/python/mozbuild/mozbuild/frontend/emitter.py", line 169, in emit
    for out in output:
  File "/Users/nchevobbe/Projects/mozilla-central/python/mozbuild/mozbuild/frontend/reader.py", line 886, in read_topsrcdir
    for r in self.read_mozbuild(path, self.config):
  File "/Users/nchevobbe/Projects/mozilla-central/python/mozbuild/mozbuild/frontend/reader.py", line 1056, in read_mozbuild
    raise bre
Sentry is attempting to send 0 pending error messages
Waiting up to 2 seconds
Press Ctrl-C to quit

When I revert Bug 1668279, I can run mach test again

Previously invocations of mach test were broken with a weird error
message:

The underlying problem is a Python syntax error on line 0:

    None

Removing the first line seems to fix that.
Now this is a Python file, so re-introducing the general mode line and a
vim line matches what others are doing too.

Assignee: nobody → jrediger
Status: NEW → ASSIGNED
Pushed by jrediger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/50e2601018cf
Don't label metrics index as utf-8. r=chutten
Duplicate of this bug: 1669505
Duplicate of this bug: 1669651
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
See Also: → 1670169
Attachment #9179821 - Attachment description: Bug 1669413 - Don't label metrics index as utf-8. r?chutten! → Bug 1669413 - Don't label metrics index as utf-8. r=chutten
You need to log in before you can comment on or make changes to this bug.