Closed Bug 1669526 Opened 1 year ago Closed 11 months ago

Don't show the heuristic result for partially typed token aliases and show all the matching token aliases

Categories

(Firefox :: Address Bar, enhancement, P2)

enhancement
Points:
3

Tracking

()

RESOLVED FIXED
84 Branch
Iteration:
84.1 - Oct 19 - Nov 01
Tracking Status
firefox84 --- fixed

People

(Reporter: mak, Assigned: harry)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

UX proposed these changes.

When typing part of a token alias:

  1. the token alias will be autofilled, but we won't show an heuristic result
  2. show all the token aliases matching the partially types alias, the autofilled one should be the first one

When pressing Enter: the autofilled token should change to search mode
When pressing down or tab: enter search mode for the selected engine (the first down/tab will in practice act the same as pressing Enter)

The idea is that Down, Tab and Enter will all allow to fill the proposed engine, then you can still tab or down to the next ones.

Points: --- → 3
Blocks: 1647921
Summary: Don't show the heuristic result for partially typed token aliases and show all the aliases matching → Don't show the heuristic result for partially typed token aliases and show all the matching token aliases
Priority: P3 → P2
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 84.1 - Oct 19 - Nov 01

The heavily nested structure of UrlbarInput.setValueFromResult made it difficult to handle a result that was both a keywordoffer and autofilled. I took this opportunity to refactor setValueFromResult to be flatter. I think it's a bit easier to read now.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6a8ad0e28878
Don't show the heuristic result for partially typed token aliases and show all the matching token aliases. r=adw
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
Duplicate of this bug: 1506952
You need to log in before you can comment on or make changes to this bug.