Reset master password not working; error dialogs misleading

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: fred, Assigned: dveditz)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
I never set a master password in Mozilla 1.1, so it must have picked one up from
1.0. Clicked Reset Master Password, got warning and clicked Reset button. Got
"Your Password has been reset" confirmation. But visiting this secure site
brings up the password dialog:
"Please enter the master password for the PSM Internal FIOS-140-Cryptogr."
Leaving it blank doesn't work. Guessing the old password was futile (although I
think I know it, it didn't work). Clicking Cancel generates this dialog (twice
in succession): 
"Could not establish an encrypted connection because certificate presented by
exchange.intervalworld.com is invalid or corrupt. Error Code: -8182"
Tried another secure site (https://secure.trendwest.com/owners/gotoLobby) and
got the same results and error code. It seems unlikely both of these sites have
bad certificates. Turning off 'Use encryption when storing sensitive data"
didn't help either.

Comment 1

16 years ago
fred, can you reproduce this problem using another Mozilla user profile?
Reassigning unconfirmed form and password manager bugs to the new owner
Assignee: morse → dveditz
MAc classic buidls are "dead"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.