Closed Bug 1669651 Opened 7 months ago Closed 7 months ago

Error in glean build files breaks mach test

Categories

(Data Platform and Tools :: Glean: SDK, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1669413

People

(Reporter: sg, Unassigned)

References

(Blocks 1 open bug)

Details

When running e.g. ./mach test --headless netwerk/cookie/test/browser/browser_indexedDB.js, I get the following error:

Test configuration changed. Regenerating backend.
Error running mach:

    ['test', '--headless', 'netwerk/cookie/test/browser/browser_indexedDB.js']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file test| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

BuildReaderError: 
==============================
FATAL ERROR PROCESSING MOZBUILD FILE
==============================

The error occurred while processing the following file:

    /home/simon/work/mozilla-unified/toolkit/components/glean/metrics_index.py

This file was included as part of processing:

    /home/simon/work/mozilla-unified/toolkit/components/glean/moz.build

The underlying problem is a Python syntax error on line 0:

    None

Fix the syntax error and try again.


  File "/home/simon/work/mozilla-unified/testing/mach_commands.py", line 319, in test
    run_suites, run_tests = resolver.resolve_metadata(what)
  File "/home/simon/work/mozilla-unified/testing/mozbase/moztest/moztest/resolve.py", line 890, in resolve_metadata
    tests = list(self.resolve_tests(paths=[relpath]))
  File "/home/simon/work/mozilla-unified/testing/mozbase/moztest/moztest/resolve.py", line 857, in resolve_tests
    for test in self._resolve(**kwargs):
  File "/home/simon/work/mozilla-unified/testing/mozbase/moztest/moztest/resolve.py", line 638, in _resolve
    if (path in self.test_dirs or
  File "/home/simon/work/mozilla-unified/testing/mozbase/moztest/moztest/resolve.py", line 555, in test_dirs
    for test in self.tests:
  File "/home/simon/work/mozilla-unified/testing/mozbase/moztest/moztest/resolve.py", line 521, in tests
    for test in self.load_tests():
  File "/home/simon/work/mozilla-unified/testing/mozbase/moztest/moztest/resolve.py", line 402, in __call__
    gen_test_backend()
  File "/home/simon/work/mozilla-unified/python/mozbuild/mozbuild/gen_test_backend.py", line 50, in gen_test_backend
    backend.consume(data)
  File "/home/simon/work/mozilla-unified/python/mozbuild/mozbuild/backend/base.py", line 128, in consume
    for obj in objs:
  File "/home/simon/work/mozilla-unified/python/mozbuild/mozbuild/frontend/emitter.py", line 169, in emit
    for out in output:
  File "/home/simon/work/mozilla-unified/python/mozbuild/mozbuild/frontend/reader.py", line 886, in read_topsrcdir
    for r in self.read_mozbuild(path, self.config):
  File "/home/simon/work/mozilla-unified/python/mozbuild/mozbuild/frontend/reader.py", line 1056, in read_mozbuild
    raise bre
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1669413
You need to log in before you can comment on or make changes to this bug.