Closed Bug 1669703 Opened 7 months ago Closed 7 months ago

The “fission.experiment.startupEnrollmentStatus” pref retains its experiment value after changing “fission.autostart”

Categories

(Core :: DOM: Navigation, defect)

Desktop
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1669536
Tracking Status
firefox83 --- affected

People

(Reporter: mheres, Unassigned)

References

(Blocks 1 open bug)

Details

[Affected versions]:

  • Firefox Nightly 83.0a1 (Build ID: 20201006161706)

[Affected Platforms]:

  • Windows 10 x64
  • Windows 7
  • macOS 10.15

[Prerequisites]:

  • Have the latest Firefox Nightly browser installed.
  • Be enrolled in the “fission-disabled” branch.
  • The browser has NOT been restarted after enrollment - Fission is still disabled.

[Steps to reproduce]:

  1. Navigate to “about:config” and modify fission.autostart to true.
  2. Restart the browser.
  3. Navigate to “about:config” again and observe the preferences.

[Expected result]:

  • Preferences are:
    • fission.experiment.enrollmentStatus set to 3.
    • fission.experiment.startupEnrollmentStatusset to 3.
    • fission.autostart set to true.

[Actual result]:

  • Preferences are:
    • fission.experiment.enrollmentStatus set to 3.
    • fission.experiment.startupEnrollmentStatusset to 1.
    • fission.autostart set to true.

[Notes]:

  • If preferences are observed between steps 1 and 2, the results are:
    • fission.experiment.enrollmentStatus set to 1.
    • fission.experiment.startupEnrollmentStatusset to 1.
    • fission.autostart set to true.
  • This pattern of preference behavior is also reproducible for the "fission-enabled" branch.
  • Attached are a recording for the treatment branch and for the control branch.

I believe this is getting fixed in 1669536

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1669536
You need to log in before you can comment on or make changes to this bug.