Closed Bug 1670114 Opened 2 years ago Closed 2 years ago

Video playback on foxnews.com is broken with ETP - Strict enabled

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

defect

Tracking

()

VERIFIED WORKSFORME
Tracking Status
firefox83 --- affected
firefox88 --- verified

People

(Reporter: cpeterson, Unassigned)

References

(Blocks 2 open bugs, )

Details

Steps to reproduce

  1. Enable ETP Strict in Fx83
  2. Load https://video.foxnews.com/v/6198810736001#sp=show-clips
  3. Click the video's play button.

Expected result

A preroll video ad should play and then the interview clip.

Actual result

The video player shows a loading spinner and no video is played.

This is interesting. I can reproduce this when changing my ip address to an US ip address, but can't reproduce it with my original ip address (Berlin).
The video can be played normally after adding c.amazon-adsystem.com to urlclassifier.trackingSkipURLs.

Blocks: tp-breakage
Severity: -- → S3
Priority: -- → P3

I can;t reproduce the issue on my side, with ETP - Strict the video plays.
https://prnt.sc/105r8xo

Tested with:
Browser / Version: Firefox Nightly 88.0a1 (2021-02-23), Firefox Nightly 210221 (🦎 87.0a1-20210218092411)
Operating System: Windows 10 Pro, Samsung Galaxy S8 (Android 9) - 1440 x 2960 pixels, 18.5:9 ratio (~570 ppi density)

Chris can you still reproduce it ?

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(cpeterson)
Resolution: --- → WORKSFORME

(In reply to Oana Arbuzov [:oanaarbuzov] from comment #2)

Chris can you still reproduce it ?

Nope. The video plays for me in 88 Nightly. Thanks for testing.

Status: RESOLVED → VERIFIED
Flags: needinfo?(cpeterson)
You need to log in before you can comment on or make changes to this bug.