Closed Bug 1670263 Opened 6 months ago Closed 6 months ago

The Fission doorhanger is dismissed by some dialogs

Categories

(Core :: DOM: Navigation, defect)

Desktop
All
defect

Tracking

()

RESOLVED WONTFIX
Fission Milestone M6b
Tracking Status
firefox81 --- unaffected
firefox82 --- unaffected
firefox83 --- affected

People

(Reporter: mheres, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

[Affected versions]:

  • Firefox Nightly 83.0a1 (Build ID:20201009041754)

[Affected Platforms]:

  • Windows 10 x64
  • macOS 10.15

[Prerequisites]:

  • Have the latest Firefox Nightly browser installed.
  • Have a new Firefox profile.
  • Have the user.js for the “fission-enabled” branch downloaded to your PC.

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites.
  2. Navigate to the "about:support" page and open the profile folder.
  3. Paste the user.js file from prerequisites and restart the browser.
  4. Restart the browser for the second time.
  5. Navigate to a website that will open a dialog after the doorhanger is displayed (e.g. Perform a google search).
  6. Observe the behavior.

[Expected result]:

  • The doorhanger is not dismissed by some dialogs.

[Actual result]:

  • The doorhanger is dismissed when some types of dialogs are displayed.

[Notes]:

  • The issue was also reproducible for "Accept cookies from Facebook on this browser?" from Facebook
  • The issue was not reproducible for “Sign in to YouTube” on Youtube.
  • Attached is a recording of the issue.

Andrei, do you know why this could be happening?

Flags: needinfo?(andrei.br92)

The doorhanger is dismissed because of the navigation event (specifically whenever the "content finished loading" event fires and we find out we're on a different origin, which happens to coincide with that overlay loading). This behavior is intended, when the user gets the doorhanger:

  • The doorhanger is not dismissed by clicking anywhere in the content or browser UI
  • The doorhanger is only dismissed by interacting with one of the two buttons

The navigation event is interpreted as dismiss.

For our "softer" doorhangers (the ones that can be dismissed simply by clicking anywhere on the current page) we set a limit of 3 impressions and separate them at least 24hrs apart. That way we're sure the user had sufficient opportunities to see and interact with the doorhanger.

Flags: needinfo?(andrei.br92)

Fixing this bug would be nice (if it doesn't require a lot of custom code to work around the expected doorhanger behavior), but I don't think this bug needs to block launching our Fission experiment.

Fission Milestone: --- → M6b

This is the built-in default behavior of the doorhanger framework that the Fission team is reusing. We will not make any modifications to the default doorhanger behavior. Closing based on comment 2.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.