Closed Bug 1670286 Opened 2 years ago Closed 2 years ago

Sync vendored puppeteer to v5.5.0

Categories

(Remote Protocol :: Agent, task, P3)

task

Tracking

(firefox85 fixed)

RESOLVED FIXED
85 Branch
Tracking Status
firefox85 --- fixed

People

(Reporter: whimboo, Assigned: impossibus)

References

(Blocks 1 open bug)

Details

(Whiteboard: [puppeteer-beta2-mvp])

Attachments

(3 files)

Version 5.3.1 is the most recent release:
https://github.com/puppeteer/puppeteer/releases/tag/v5.3.1

Maja, you wanted to do that. Maybe you can schedule it for next week?

Flags: needinfo?(mjzffr)

Maybe... it's not particularly time sensitive, but I'm sure I'll get to it eventually.

Flags: needinfo?(mjzffr)

Mark tried that for bug 1666172 here:
https://hg.mozilla.org/try/rev/b4ebc58c98fa049ee052a32f18e0f75f1db7a977

Maybe we could use it? When checking the diff there are tons of .md files included now. I wonder if we should not sync those?

I see an install error in that try push, so there might be some environment work to.

Summary: Sync vendored puppeteer to v5.3.x → Sync vendored puppeteer to v5.4.x
Assignee: nobody → mjzffr
Status: NEW → ASSIGNED
Summary: Sync vendored puppeteer to v5.4.x → Sync vendored puppeteer to v5.5.0

Looks like I'll have to investigate a new crash/hang in order to complete the sync. https://treeherder.mozilla.org/logviewer?job_id=322329730&repo=try&lineNumber=8256

Also, the tests run in a completely different order when called with ./mach puppeteer-test in m-c versus npm run unit in the Puppeteer repo. DEBUG=mocha:* claims that mocha is running the tests in alpha order in both cases, but when run via mach it starts with page.spec.js. All the tests run in both cases. Perhaps this doesn't matter, but it's at least disconcerting. *shakes fist a mocha*

Does mach also call npm run unit or do we set some different options?

Bahaha, I forgot to remove a describe.only call so only the Page tests were being run. 🤦

Pushed by mjzffr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c97179fc8830
[puppeteer] Remove unwanted docs directories when vendoring r=remote-protocol-reviewers,whimboo
https://hg.mozilla.org/integration/autoland/rev/39b40e265fbd
[puppeteer] Sync vendored puppeteer to v5.5.0 r=remote-protocol-reviewers,whimboo
https://hg.mozilla.org/integration/autoland/rev/b69314711926
[remote] Update Puppeteer-vendoring documentation r=remote-protocol-reviewers,whimboo
Regressions: 1683392
You need to log in before you can comment on or make changes to this bug.