Closed Bug 1670480 Opened 1 year ago Closed 2 months ago

The DevTools theme cannot be set to follow the operating system's theme

Categories

(DevTools :: CSS and Themes, defect)

Firefox 83
defect

Tracking

(firefox95 fixed)

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: nassomails, Assigned: emilio)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0

Steps to reproduce:

  • Changed my operating system theme preference to dark or light (whichever is the opposite of my currently set DevTools theme)

Actual results:

  • Firefox updated its theme to follow the new preference.
  • Every other application on my operating system also updated their color scheme.
  • The DevTools window stayed on its own theme.

Expected results:

  • The DevTools window should have a setting to follow the operating system color scheme like any other app.
  • Alternatively, it could also have a setting to follow Firefox's theme, since Firefox's "default" theme already follows the operating system.

This would be particularly useful for those with a color scheme set after the current time.

Moving to defect to get it through DevTools triage

Type: enhancement → defect

We have JS listeners that are expected to run once the LookAndFeel
caches have been cleared and such, so split the look-and-feel-changed
notification into an internal and external notification.

Assignee: nobody → emilio
Attachment #9245272 - Attachment description: WIP: Bug 1670480 - WIP → Bug 1670480 - Add an "auto" theme for devtools which follows the browser's color scheme. r=jdescottes!
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/35889682fd07
Ensure look-and-feel-changed listeners can rely on LookAndFeel values returning updated styles. r=jwatt
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/81a98f3eb838
Add an "auto" theme for devtools which follows the browser's color scheme. r=jdescottes
Duplicate of this bug: 1728885
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.