Closed Bug 167050 Opened 18 years ago Closed 18 years ago

javascript bookmarks don't work (most of the time)

Categories

(Camino Graveyard :: Bookmarks, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: chimera, Assigned: sfraser_bugs)

References

()

Details

Hi,

bookmarks like this:

javascript:void(window.open('http://config.privoxy.org/toggle?mini=y','ijbstatus','width=250,height=100,resizable=yes,scrollbars=no,toolbar=no,location=no,directories=no,status=no,menubar=no,copyhistory=no').focus());

don't work up to and including the latest chimera release.
(They sometimes work, I can't figure out when.)

Pretty anoying as I have many of those :-)
is this a side effect of the pref for disabling popup windows?

Dominik Westner--If you find a JS bookmark that does work, please add it here :)
is this a side effect of the pref for disabling popup windows?
You mean because I use privoxy? No, not at all. It already happened before I used 
privoxy at all (e.g. with the 'My Bookmarks' bookmark link for skramkoob.com).

WorksForMe using Chimera/2002090505 on 10.1.5. I create a bookmark with that URL
and it opens a small window that says, "Privoxy not working."

Dominik, what build ID are you reporting this bug against?
sometimes it works, but most of the time it doesnt. (This has been the case with all the 
builds I have tried during the last month.
This is build id: 2002090505.
If you want to try a simpler example, try this;
javascript:void(open('about:blank'));

Works perfectly in IE and Mozilla, but doesn't in Chimera.
Dominik: edit your chimera prefs.js file and remove the lines

user_pref("dom.disable_open_click_delay", 1000);
user_pref("dom.disable_open_during_load", true);

(while chimera is not running). Then try your tests again.
Simon, 

thanks. Your suggestion seems to fix the problem. It did not occure anymore so far.
Domink
If this bug is a result of click_delay, it's a dup of bug 143423 (although
Chimera probably shouldn't be using click_delay).  If it's a result of
open_during_load, it might be a Chimera bug.
*** Bug 176638 has been marked as a duplicate of this bug. ***
i have a bookmarklet which works even when i have popups disabled. tested with
2002.10.25.14, marking wfm.
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
Does NOT work for me.  Build ID 2002102504, new profile, 10.2 on a TiBook

Test case:

1) with Chimera NOT running, create a new profile, or delete prefs.js in existing profile
2) run Chimera and expose the bookmark drawer
3) create a new bookmark "Test" and set its location to the following:

javascript:void(window.open('http://www.mozilla.org','foo','scrollbars=no,width=
400,height=460,status=yes,resizable=yes,scrollbars=yes'))

4) select "Test" from the bookmark drawer.  Note that the popup appears as expected.  
Close the popup window.
5) go to Preferences -> Web Features, check Enable Popup Blocking.  Close 
Preferences
6) select "Test" from the bookmark drawer.  Note that the popup does NOT appear.
7) go to Preferences -> Web Features, uncheck Enable Popup Blocking.  Close 
Preferences
8) select "Test" from the bookmark drawer.  Note that the popup again appears, as 
expected.
9) quit Chimera
You need to log in before you can comment on or make changes to this bug.