Closed Bug 1671000 Opened 1 year ago Closed 1 month ago

Highlighted bookmarks label is covered by scroll arrow icon while the menupopup is scrolling with key board

Categories

(Toolkit :: XUL Widgets, defect, P3)

Firefox 81
Desktop
All
defect

Tracking

()

VERIFIED FIXED
95 Branch
Iteration:
95.2 - Oct 18 - Oct 31
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- wontfix
firefox81 --- wontfix
firefox82 --- wontfix
firefox83 --- wontfix
firefox84 --- wontfix
firefox85 --- wontfix
firefox91 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- wontfix
firefox95 --- verified

People

(Reporter: alice0775, Assigned: dao)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: nightly-community, regression, ux-userfeedback)

Attachments

(1 file)

Reproducible: always

Steps To Reproduce:

  1. Put a lot of bookmarks so that bookmarks menupopup will overflow
  2. Open the bookmarks menu
  3. Scroll using up/down arrow key and repeat

Actual Results:
Highlighted bookmarks label is covered by scroll arrow icon while the menupopup is scrolling with key board. I cant read it.

Expected Results:
Highlighted bookmarks label should not covered by scroll arrow icon

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e934784933a92d84618b9552569bbc701fe129b4&tochange=24e5d7050b142a98b88b3317cbaceb61d586fba4

Severity: -- → S3
Component: Bookmarks & History → Themes
OS: Windows 10 → All
Priority: -- → P3
Product: Firefox → Toolkit

Hi Dao, could you please look at this one, thank you!

Flags: needinfo?(dao+bmo)
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Iteration: --- → 95.2 - Oct 18 - Oct 31
Flags: needinfo?(dao+bmo)
Component: Themes → XUL Widgets
Blocks: 1737106
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/716295d23677
When activating items in menu popups, stay clear of overlapping scroll buttons. r=mstange

Backed out changeset 716295d23677 (Bug 1671000) for causing mochitest failures on test_menulist_paging.xhtml.
Backout link
Push with failures - c3
Failure Log

Flags: needinfo?(dao+bmo)
Flags: needinfo?(dao+bmo)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d0331eb037a0
When activating items in menu popups, stay clear of overlapping scroll buttons. r=mstange
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

I think this code might cause problems when the scrollbuttons are hidden with display: none since they'll have no dimensions. I stumbled on it trying to figure out why my menupopups are scrolling to the very bottom every time I hover a menuitem. Well, it's because I hide the scroll buttons, but there are lots of author sheets for popups and there may be need to hide them with display rather than visibility. So maybe there should be a check in there, not just for overflowing or menulist but for the scrollbuttons actually having dimensions, or checking the computed display property, whichever is faster. Since the dimensions need to be retrieved anyway I assume it's faster to just check that height and width aren't both zero

Flags: qe-verify+

Reproduced the initial issue using Firefox 83.0a1 (20201013094053) on Windows 10x64 and STR from comment 0.
The issue is no longer reproducible with Firefox 95.0b2 (20211102190739) on Windows 10x64, macOS 10.15 and Ubuntu 21.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.