Closed Bug 1671131 Opened 11 months ago Closed 11 months ago

printing broken again on trunk - Print dialog come up but will not send output to printer

Categories

(Thunderbird :: General, defect, P1)

Thunderbird 83

Tracking

(thunderbird_esr78 unaffected, thunderbird83+ fixed)

RESOLVED FIXED
84 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird83 + fixed

People

(Reporter: paul, Assigned: rnons)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.75 Safari/537.36

Steps to reproduce:

this is related to 2020-10-12 83.01a version

alt-f / p

print dialouge comes up ok

Actual results:

click print no output

Expected results:

output should have printed

note backgraded to 2020-10-08 all working ok

Confirmed (no output for Print to file)

Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Keywords: regression
Priority: -- → P1
Summary: Print dialog come up but will not send output to printer → printing broken again on trunk - Print dialog come up but will not send output to printer

I see this in the console now:
Uncaught TypeError: can't access property "outerWindowId", aBrowsingContext.currentWindowGlobal is undefined
printWindow chrome://global/content/printUtils.js:306
startPrintWindow chrome://global/content/printUtils.js:293
getContentWindowOrOpenURI chrome://messenger/content/mailWindow.js:754
createContentWindow chrome://messenger/content/mailWindow.js:708

Print preview doesn't work either
Uncaught TypeError: can't access property "getSourceBrowser", aListenerObj is undefined
printPreview chrome://global/content/printUtils.js:409
observe chrome://messenger/content/msgPrintEngine.js:86
printUtils.js:409:7

Ping, can you look at this ASAP?

Assignee: nobody → remotenonsense
See Also: → 1667557
Attached patch 1671131.patchSplinter Review

Bug 1669925 added an extra argument to printPreview and startPrintWindow for telemetry purpose. This patch ports it to c-c, sadly this only fixes printing. Print preview crashes with no error message now, will investigate more.

Attachment #9182536 - Flags: review?(mkmelin+mozilla)
Status: NEW → ASSIGNED
Comment on attachment 9182536 [details] [diff] [review]
1671131.patch

Review of attachment 9182536 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, seems to work! r=mkmelin
Attachment #9182536 - Flags: review?(mkmelin+mozilla) → review+

We'll need this for beta.

Severity: -- → S2
Target Milestone: --- → 84 Branch
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Comment on attachment 9182536 [details] [diff] [review]
1671131.patch

[Approval Request Comment]
Regression caused by (bug #): bug 1669925
User impact if declined: can't print
Testing completed (on c-c, etc.): landed on comm-central
Risk to taking this patch (and alternatives if risky): not much risk as printing is completely broken without it

Attachment #9182536 - Flags: approval-comm-beta?
Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/b66fdf9b7398
followup - fix quotes to make viewSource.xhtml valid xml. rs=bustage-fix DONTBUILD

Sorry, I also missed a few changes to printWindow, will send a patch soon.

(In reply to Ping Chen (:rnons) from comment #12)

Sorry, I also missed a few changes to printWindow, will send a patch soon.

Never mind, it was startPrintWindow changed, no missing. However, print in viewSource window doesn't work, don't know why.

Comment on attachment 9182536 [details] [diff] [review]
1671131.patch

[Triage Comment]
Approved for beta

Attachment #9182536 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.