Image displays as line only 2 pixels high.

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: paul, Assigned: karnaze)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

I sent the following e-mail to support@photoASA.com describing the problem:

When I sign on and display a photo index, all the pictures display normally, but
when I select an individual picture, it's displayed as a line of length the same
as the picture but only 2 pixels high. I was using login name=mapsolk,
password=5678.

I looked at the html source and saw the following fragment for displaying the
picture:

<table border=0 cellpadding=2 cellspacing=0>
    <tr>
	<td align=center><font face="Helvetica,Arial" size="2" color="#BB0000"><b>Macro
mode</b></font></td></tr>
    <tr>	  
	<td align=center>

	<img src="http://www.photoasa.com/disk4/6733/171170_Jun16_45.JPG"
alt="Jun16_45.JPG" width=640 height=480&id=%ld></td>
    </tr>
	<tr>
	<td align=center><br><font face="Helvetica,Arial" size="2"
color="#0000BB"><b><i>Photo Name: Jun16_45.JPG</i></b></font></td>
    </tr>
  </table>

There appears to be a spurious "&id=%ld" after the "height=480" specification,
causing the browser to display the picture incorrectly. Internet Explorer 6
displays the picture correctly.

Since Mozilla handles this situation differently from Internet Explorer, I am
also reporting this to Mozilla.

Regards,

Paul Walukewicz
paul@walukewicz.com

Reproducible: Always

Steps to Reproduce:
1. Go to web page www.photoasa.com
2. Enter mapsolk for login and 5678 for password
3. Select any picture

Actual Results:  
Picture displays as line 640 pixels long and 2 pixels high.

Expected Results:  
I'm not sure, since the html code doesn't look right. Internet Explorer 6
displays the picture correctly and doesn't produce any error messages.

Comment 1

16 years ago
Same with Mac OS 9.1, Build 20020903099

Works with NS4
This sounds like the "%-height inside table cell" thing that was fixed
recently... I cannot reproduce the bug with today's build....
Assignee: pavlov → karnaze
Component: Image: Layout → HTMLTables
QA Contact: tpreston → amar

Comment 3

16 years ago
Exact. WFM now with Build 2002090608
(Reporter)

Comment 4

16 years ago
Just got the following e-mail from support at photoasa.com saying that they
fixed the html problem, so this problem is no longer reproducable at their site:

> From: "Support Team @ PhotoASA.com"
> <support@photoasa.com>
> To: <paul@walukewicz.com>
> Subject: Re: Problem using Mozilla 1.1 browser to
> display pictures
> Date: Sat, 7 Sep 2002 15:20:10 -0700
> 
> Thank you for reporting this issue.
> 
> It has been fixed now.
> 

Comment 5

16 years ago
 From the above comments marking this bug WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.