Closed Bug 16715 Opened 20 years ago Closed 20 years ago

[DOGFOOD] Do not see blinking or still cursor after hitting the Enter/Return key

Categories

(Core :: DOM: Editor, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: bijals, Assigned: mozeditor)

References

Details

(Whiteboard: [PDT+][by 12/3] will verify on 12/7 build.)

Steps:
1) Open a blank page
2) Type some text such as "asdf"
3) Hit return

Actual Results: Do not see cursor on the next line.

Expected Results: Cursor blinking or still on the next line

Build # and Platform: 1999101808 on WinNT
This also affects TEXTAREA elements in the browser. Surely the same code
is being invoked.

BTW, the proper terminology is "caret". The cursor is the visual
indicator of the location of the mouse pointer; the caret is the
visual indicator of the current text insertion point.
Priority: P3 → P2
Target Milestone: M12
Simon, setting this to M12, I think this is related to the problems discussed
yesterday in our team meeting
Whiteboard: [CURSOR FOCUS]
adding info in sw
Whiteboard: [CURSOR FOCUS] → [CARET FOCUS]
Assignee: sfraser → jfrancis
Didn't you just fix this joe?
i'm working on this.
*** Bug 18810 has been marked as a duplicate of this bug. ***
Summary: Do not see blinking or still cursor after hitting the Enter/Return key → [DOGFOOD] Do not see blinking or still cursor after hitting the Enter/Return key
This is really screwing me up on plaintext mail compose,
I am voting this in as a dogfood candidate and marking it so.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
i think this is a dup of 18869 which is a PDT+ bug...yep...this needs a fix.  We
must have mcafee happy !

*** This bug has been marked as a duplicate of 18869 ***
Status: RESOLVED → REOPENED
Depends on: 18869
This is not a duplicate of 18869.  In fact, 18869 needs to be fixed before this
bug can be reproduced.

Reopening bug.
Whiteboard: [CARET FOCUS] → [PDT+][CARET FOCUS]
Resolution: DUPLICATE → ---
Clearing Duplicate resolution due to reopen.  Putting on PDT+ radar
it's coming.  really.  no, really!  This will be part of the next large
"reworking everything once again" checkin that will likely land on sunday.  Then
everyone can tell me how much they liked the old way better!  :-P
*** Bug 19192 has been marked as a duplicate of this bug. ***
Whiteboard: [PDT+][CARET FOCUS] → [PDT+][by 12/3]
I have the fix for this.  It's part of a mongo checkin that I will try to get in
in the next 24 hours.
Blocks: 12658
this is fixed, but soe other bugs make it appear only partially fixed.  Some
notes:

1) My fix only applies to html editors right now.  I'll port the work over to
plaintext editors soon.  (so mcafee won't see improvement in plaintext yet)

2) There is a seperate bug that can cause the caret to disappear despite my
efforts in the editor (see bug 20106).  This may block verification.  One way you
can tell that we have made some forward progess here is to not that you do get a
blank line when you hit return now at the end of the document.

I'll leave this open for now - I'm hoping to get in a plaintext fix soon.
Interested parties can play with the html editor now to see the behavior.

PDT status unchanged: should be fixed before 12/3.
*** Bug 17908 has been marked as a duplicate of this bug. ***
*** Bug 19405 has been marked as a duplicate of this bug. ***
adding myself to cc: list as this affects mail compose as well.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
First off, my earlier comment had a bad typo.  It should have read (in part):
"One way you can tell that we have made some forward progess here is to NOTE that
you do get a blank line when you hit return now at the end of the document."

Secondly, I have adapted the work I did for the html editor and checked in a fix
for plaintext as well.  Textfields, Textareas, plaintext mail should all have
better behavior now.  Note that Bug 20106 may still make the caret disappear in
this (and other) circumstances, but it's not the same bug.

Marking fixed.  Now we need to fix 20106.  God save the Queen.
Whiteboard: [PDT+][by 12/3] → [PDT+][by 12/3] can't verify until 20106 is fixed.
Whiteboard: [PDT+][by 12/3] can't verify until 20106 is fixed. → [PDT+][by 12/3] will verify on 12/7 build.
will verify on 12/7 build.
Status: RESOLVED → VERIFIED
verified in 12/7 build.
*** Bug 19205 has been marked as a duplicate of this bug. ***
The cursor is positioned one line down from where it should be. Although typing
proves that the real cursor is where it's supposed to be. using winNT build
2000021708. I think bug 19242 is blocked by this.
You need to log in before you can comment on or make changes to this bug.