Closed Bug 1671564 Opened 8 months ago Closed 7 months ago

Email summary of signatures prior to deleting them

Categories

(Tree Management :: Perfherder, task, P1)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: igoldan, Assigned: beatrice.acasandrei)

References

Details

Attachments

(1 file)

Prior to deleting performance signatures, we should compile a summary of them & email that to our FxPerfTest team.
This will give us some basic awareness of what the data retention is removing.

We'll use Taskcluster's notify service for sending our emails.

The receivers are: perf-sheriffs@mozilla.com perftest-alerts@mozilla.com, dhunt@mozilla.com
The message body should leverage the markdown syntax & present an acceptable number of signatures inside a table.
In case there are too many signatures, send multiple emails.
In case there will be too many emails, we should postpone removal of the rest of the signatures for the following days.

The required credentials will be provided for this issue.
Jira link: https://jira.mozilla.com/browse/FXP-1369

Sure thing.

Seems like we need credentials that have the notify:email:<address> scope.

Depends on: 1672397
Depends on: 1680807
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
See Also: → 1685037
Duplicate of this bug: 1571379
You need to log in before you can comment on or make changes to this bug.