Closed Bug 1671588 Opened 6 months ago Closed 5 months ago

PiP window is not visible if enabled right after changing resolution

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

defect

Tracking

()

VERIFIED FIXED
84 Branch
Tracking Status
firefox-esr78 --- wontfix
firefox81 --- wontfix
firefox82 --- wontfix
firefox83 --- wontfix
firefox84 --- verified

People

(Reporter: simona.marcu, Assigned: baumga91)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached video 2020-10-16_14h47_49.mp4

Affected versions

Firefox Nightly 83.0a1

Affected platforms

Windows 10

Steps to reproduce

  1. Navigate to Youtube.
  2. Start playing any video at a 720p resolution.
  3. Change the resolution of the video to 1080p and right after toggle the PiP button.

Expected result

The PiP window should be properly opened.

Actual Result

The PiP window is seen in the TaskBar but can't be accessed. Please see the screencast for more details.
If this issue is a regression, is not a recent one since I've reproduced it on Firefox 78.3.1 esr, Firefox 81.0.2, and Firefox 82. I'll investigate more as soon as possible.

Severity-Suggestion:

S3 severity.

Not a regression, reproduced this issue ever since Nightly 69.0a1.

Blocks: videopip, 1662870
Severity: -- → S3
Priority: -- → P3
Assignee: nobody → baumga91
Status: NEW → ASSIGNED
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/533c8598febd
The Picture-in-Picture toggle is updated after changing video source. r=mconley
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
Flags: qe-verify+

This issue is Verified as fixed in our latest Beta build 84.0b3

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.