Last Comment Bug 167167 - manage bookmarks causes hang
: manage bookmarks causes hang
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: unspecified
: x86 Windows 2000
: -- normal (vote)
: Phoenix0.2
Assigned To: Pierre Chanial
: Asa Dotzler [:asa]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-06 13:33 PDT by Matt Kraai
Modified: 2002-09-30 15:39 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Matt Kraai 2002-09-06 13:33:01 PDT
When I choose Manage Bookmarks from the Bookmarks menu, or press Ctrl+B, Phoenix
hangs.
Comment 1 Matt Kraai 2002-09-06 15:33:47 PDT
Now it works fine.  Nevermind.
Comment 2 Asa Dotzler [:asa] 2002-09-06 19:23:52 PDT
verified with current build on windows and linux. 
Comment 3 Pierre Chanial 2002-09-15 11:08:55 PDT
I see this hang on linux today's build. To reproduce it: quickly type 'moz' in
the find textbox
Comment 4 Asa Dotzler [:asa] 2002-09-15 11:52:12 PDT
I cannot reproduce any hang on windows. I've tried repeatedly to launch
bookmarks in different ways. I've tried with default bookmarks and I've tried
with several of my bookmarks files. I tried as pch suggested and quickly typed
into the quicksearch field and still no hang. I'll try on Linux tomorrow.
Comment 5 Asa Dotzler [:asa] 2002-09-18 20:38:23 PDT
OK. I was able to reproduce by doing a manage bookmarks, then a quick search.
will try to get better steps later tonight or tomorrow. If this proves to be
easy to trigger then we'll probably want a fix for 0.1
Comment 6 Pierre Chanial 2002-09-19 04:50:49 PDT
I won't have time to investigate it for 0.1
Comment 7 Asa Dotzler [:asa] 2002-09-19 13:37:34 PDT
I cannot come up with consistent steps to reproduce this. It seems pretty
random. I was twice able to reproduce it by typing in the quicksearch field. 
Comment 8 bill rees 2002-09-24 22:39:35 PDT
unable to import bookmarks I exported from Mozilla.  This works when the ends are
both mozilla.

Also unable to export from Phoenix at all.  
Comment 9 Pierre Chanial 2002-09-26 05:50:49 PDT
I don't see the hang anymore...
today's linux build
Comment 10 Eric Hoch 2002-09-26 11:01:22 PDT
like bill unable to import bookmarks which were exported from Mozilla 1.1 
Exporting Bookmarks works.

Operating System is Windows XP Pro
Comment 11 Asa Dotzler [:asa] 2002-09-26 22:59:23 PDT
bill and eric, this bug has nothing to do with import or export. Please do not
add comments which are about different problems than the one reported. All that
does is make fixing and verifying this bug more difficult. Thanks. 

pierre, I also have not seen any hangs using bookmarks today testing linux.
Comment 12 Pierre Chanial 2002-09-28 10:24:01 PDT
still seen, test case:
- open the bm manager
- close the folder, so that you have few rows in the tree. Let's say rowCount=N
- type sth in the quick search toolbar, so that you end up with more than N rows
- select a row with a an index > N
- clear the search pattern

hang

I think it's the same cause than bug 168410, bug 168727 and another bug I hit in
my tree, namely that selection.currentIndex is not correctly updated/cleared
during rebuild.
Comment 13 Pierre Chanial 2002-09-29 18:16:53 PDT
Additional info: the hang occur when the first visible row is not 0 (there must
be a scrollbar, apparently)
Anyway, I have a workaround by setting selection.current=-1 before rebuilding
-> hope it's fixed
Comment 14 Asa Dotzler [:asa] 2002-09-30 15:39:31 PDT
Verified. Unable to reproduce with the steps in comments #12 and #13

Note You need to log in before you can comment on or make changes to this bug.