Closed Bug 1671702 Opened 6 months ago Closed 2 months ago

Add "Flip on side edge"/"Flip on top edge" options to new print UI (duplex printing)

Categories

(Toolkit :: Printing, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
87 Branch
Tracking Status
firefox87 --- fixed

People

(Reporter: nordzilla, Assigned: emilio, NeedInfo)

References

(Blocks 1 open bug)

Details

(Whiteboard: [print2020_v88] [old-ui-] )

Attachments

(1 file)

Bug 1666734 adds a checkbox for duplex-printing on both sides, but it is strictly restricted to a book-like horizontal page flip.

This patch would introduce options to choose between a book-like flip, or a calendar-line vertical/tumble flip.

This is required for parity with the legacy UI and parity with Chrome.

We need some UX input on this. I suspect a picture will be worth many words here. So, we show the choices graphically which edge will be used to which effect, rather than trying to come up with text labels that will fit in our narrow UI and translate unambiguously.

Whiteboard: [print2020_v83][old-ui-] → [print2020_v84][old-ui-]
Depends on: 1673099
No longer depends on: 1666734
Summary: Add "Flip on long edge"/"Flip on short edge" options to new print UI (duplex printing) → Add "Flip on side edge"/"Flip on top edge" options to new print UI (duplex printing)

(I don't think this is going to land in time for 84, so punting it to 85.)

Whiteboard: [print2020_v84][old-ui-] → [print2020_v85][old-ui-]

CCing abenson, since this is the relevant bug for the side-edge/top-edge icons.

(Moving bugs to 86, part 1.)

Whiteboard: [print2020_v85][old-ui-] → [print2020_v86][old-ui-]

Moving things to 88, cause we're mostly on Proton these days…

Whiteboard: [print2020_v86][old-ui-] → [print2020_v88] [old-ui-]

abenson, do you have any updates on when we might be able to get these duplex-print flip-direction icons for the print UI?

Flags: needinfo?(abenson)
Duplicate of this bug: 1691564

Can we just make it a <select>, for now? GTK uses "Long Edge (Standard)" and "Short Edge (Flip)" as the select string, and I think they're not too long for our narrow UI.

We can't wait forever for icons, and exposing the functionality using a
<select> is trivial and can be changed later easily if we come up with
a better UI.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
See Also: → 1689412

Safari only has a checkbox for this, and no way to choose which side to flip on.
Chrome doesn't seem to offer duplex printing on MacOS at all!
HP Printers on Windows seem to use:
"1 sided print", "Flip on long edge", and "Flip on short edge", which feels a little nicer to me than the strings above.
bug given the label of "Two sided printing", I might suggest "Off" as the first value.

(Oh, also, we're using "Sentence case" for the strings as of a little while ago, so whatever we go with should follow that.)

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/01455295d94c
Expose both duplex print settings from the print UI. r=sfoster,fluent-reviewers,nordzilla

(In reply to Blake Winton (:bwinton) (:☕️) from comment #10)

Safari only has a checkbox for this, and no way to choose which side to flip on.

Just correcting the record: in my case (on a 2019 MBP with MacOS Big Sur), Safari offers me a checkbox and also a dropdown menu to configure this, allowing me to pick which side to flip on.

STR to see the "which side" options in Safari:
(1) start a multi-page print operation, with a duplex printer selected
(2) click the "show me more buckets of options" dropdown-menu, near the bottom-right of their print dialog (which initially says "Safari")
(3) Choose the "Layout" entry in that menu
That gives me a dropdown menu, labeled "Two-Sided", with options "None | Long-Edge Binding | Short-Edge Binding | Booklet"

Before localization happens, we might want to change the wording here to be in terms of Long-edge vs. short-edge, since that's actually what the options currently map to (it's a subtle but important distinction); alternately, if we keep the language as it stands here, we'll need some internal work to make it consistently correct. I filed bug 1692316 on handling this.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch
You need to log in before you can comment on or make changes to this bug.