Closed Bug 167207 Opened 20 years ago Closed 20 years ago

crash on attempting to type into any form control

Categories

(SeaMonkey :: UI Design, defect, P1)

x86
Windows 2000
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME
mozilla1.2alpha

People

(Reporter: mjl+bmo, Assigned: aaronlev)

References

()

Details

(Keywords: crash)

using today's trunk 2002090608 (win2k installer)

1. go to any page with a form, e.g. http://www.google.com/ (b.m.o homepage was
where i saw it first)
2. click in text box to give it focus
3. type a letter

mozilla crashes as soon as the key is pressed.

talkbacks TB10497602H and TB10498270X
Keywords: crash, stackwanted
0x00000044
nsSupportsArray::InsertElementAt
[c:/builds/seamonkey/mozilla/xpcom/ds/nsSupportsArray.cpp, line 407]
nsSupportsArray::AppendElement
[c:/builds/seamonkey/mozilla/xpcom/build/../ds\nsSupportsArray.h, line 78]
nsScrollPortView::AddScrollPositionListener
[c:/builds/seamonkey/mozilla/view/src/nsScrollPortView.cpp, line 130]
nsTypeAheadFind::CancelFind
[c:/builds/seamonkey/mozilla/extensions/typeaheadfind/src/nsTypeAheadFind.cpp,
line 1493]
nsTypeAheadFind::UseInWindow
[c:/builds/seamonkey/mozilla/extensions/typeaheadfind/src/nsTypeAheadFind.cpp,
line 410]
nsTypeAheadFind::KeyPress
[c:/builds/seamonkey/mozilla/extensions/typeaheadfind/src/nsTypeAheadFind.cpp,
line 482]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1615]
nsWindowRoot::HandleChromeEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsWindowRoot.cpp, line 182]
GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 762]
nsXULDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp, line 2599]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3458]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3451]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3451]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3451]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3451]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3451]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3451]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3451]
nsXULElement::HandleChromeEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 4688]
GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 762]
nsDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsDocument.cpp, line 3526]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2014]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsHTMLFormElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLFormElement.cpp,
line 720]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2008]
nsHTMLInputElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLInputElement.cpp,
line 1455]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6120]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6043]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2046]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 301]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1903]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1038]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1055]
nsWindow::DispatchKeyEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 2886]
nsWindow::OnChar [c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp,
line 3066]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3712]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1304]
USER32.DLL + 0x1b60 (0x77e11b60)
USER32.DLL + 0x1cca (0x77e11cca)
USER32.DLL + 0x83f1 (0x77e183f1)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 472]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1524]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1871]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1889]
WinMainCRTStartup()
KERNEL32.DLL + 0xd326 (0x77e8d326) 
I can confirm this bug with todays build on, again, Win2K. I'm not 100% sure but
I suspect nsTypeAheadFind.cpp to be the cause of this bug. Both me and Michael
had this enabled, as can be seen in the Talkback data.
Status: UNCONFIRMED → NEW
Ever confirmed: true
definitely something to do with typeaheadfind - I moved typeaheadfind.dll and
typeaheadfind.xpt out of the mozilla/components folder and now this build works
fine.

reassigning based on that...
Assignee: asa → aaronl
Blocks: isearch
Severity: blocker → critical
Component: Browser-General → XP Apps
I think I know what happened. The new typeaheadfind.dll and libtypeaheadfind.so
files were missing from the install, because I forgot to checkin typeaheadfind.jst.

So, your old typeaheadfind.dll would have been in that directory still, and it
would have called out to other dll's as if they were older versions than the new
ones that were just installed, thus the dll's were out of sync.

I think new install tomorrow will not have this problem.
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla1.2alpha
Actually, if you manually extract typeaheadfind.dll and typeaheadfind.xpt to
from typeaheadfind.xpi in today's build, it shouldn't have this problem, thus
proving my theory.

You can extract it from the zip download, or run mozilla-win32-installer /u
Either way you can get to the xpi directly and unzip the files from that.

Does someone want to try it?
cool - i didn't know about the /u switch. glad you mentioned that or I would've
had to wait half an hour for the zip download.

the files were indeed missing - when I nuked the whole mozilla directory,
installed the 090608 installer, the files did not appear.

after extracting them from the XPI manually, everything worked fine.  so I guess
if today's (Sept 7th) installer installs those files, we're ok...
Keywords: stackwanted
WFM in 2002090704.  files are installed as they should be.  no crash, and
TypeAheadFind works fine.  :)
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Phew! WFM too in 9/7 installer.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.