Closed Bug 1672101 Opened 3 months ago Closed 1 month ago

After every update search providers is reset (elementaryOS)

Categories

(Firefox :: Search, defect)

Firefox 81
defect

Tracking

()

RESOLVED MOVED

People

(Reporter: u672466, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:81.0) Gecko/20100101 Firefox/81.0

Steps to reproduce:

Update Firefox with AppCenter (OS: elementaryOS)
Start Firefox
Language is then English and I have to add German language again by hand
My preferred search provider are removed (Qwant, Startpage, Metager, Searx) and replaced by e.g. Amazon, Google, Wikipedia, Ecosia....and then I have to manually remove the the unwanted search providers and have to add my preferred search providers by hand.

Actual results:

Language settings and search providers are resetted on every update

Expected results:

The settings should stay like before the update and nothing should be changed, added etc.

This should be fixed in 82 by bug 1646016. But, if the updated language packs are provided by your OS and not at the same time of the main build, the problem will remain.

OK, thanks for your answer. Then I have to wait for the release of version 82.
In bug 164606 is only the language problem mentioned not that the custom search providers are removed too during update or sometimes just some already deleted search providers are re-added (Amazon, Ecosis...etc). Is this also fixed in version 82?

I think that's a consequence of the language change, at least for the default search engines.

Hi,

@neon, could you please re-test the issue in Release version 82 and let us know if the issue is fixed or its still reproducible on your end?

Thanks.

Flags: needinfo?(neon3k+bugzilla)

(In reply to Alin Ilea from comment #4)

Hi,

@neon, could you please re-test the issue in Release version 82 and let us know if the issue is fixed or its still reproducible on your end?

Thanks.

Hi Alin,
sure. But until now 82 is not available in ubuntu repo.

Flags: needinfo?(neon3k+bugzilla)

(In reply to neon3k+bugzilla from comment #5)

(In reply to Alin Ilea from comment #4)

Hi,

@neon, could you please re-test the issue in Release version 82 and let us know if the issue is fixed or its still reproducible on your end?

Thanks.

Hi Alin,
sure. But until now 82 is not available in ubuntu repo.

Oh sorry I somehow removed the "flag: needinfo", but I didn't found how to re-add....

I updated today to 82. Same issue: Language reset and search provider which I already deleted were added again to the list of installed search providers.

Probably I will see the effect of the fix with the next update?!?

Today's update to 82.0.2 was installed without any issue. So it seems to be fixed.

Thank you!

Thanks for the update. Based on comment 8 I will close this issue as resolved - worksforme. If the issue will appear again please feel free to reopen this bug.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Todays firefox update to 83 made the issue appear again. My language was reset (from german to english), and search providers (amazon and wikipedia) were added again.

Please tell me what informations do you need. Then I will give my best to provide the needed informations!

Ok language was switched automatically today without any action from my side. But still get during an update search providers [amazon, ebay, ecosia, wikipedia, leo] re-added which I delete every update.
Is there probably a hidden option to prevent this?

Is there anything which I could provide to narrow down the issue?

Flags: needinfo?(francesco.lodolo)
Flags: needinfo?(alin.ilea)

My only suggestion would be to try using the official mozilla.org build for a while, and see if you have the same problem. As I said, the language switch should be fixed at this point.

Flags: needinfo?(francesco.lodolo)
Flags: needinfo?(alin.ilea)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Preferences

Thanks Neon, it sounds like the only issue remaining is now the search providers being reset so I am adjusting the bug summary.

Mike, is this something your team can look into? Is the issue similar to bug 1646016?

Flags: needinfo?(mdeboer)
Summary: After every update language settings and list of search providers is reset → After every update search providers is reset

Thanks jaws, yes that is correct search providers were reset during last update to 83

Flags: needinfo?(mdeboer) → needinfo?(standard8)

How are you installing the language changes? Are you doing that from within Firefox, or manually via the command line / Synaptic.

It sounds very much like you're probably changing it within Firefox, and you're coming across this issue: https://github.com/elementary/appcenter/issues/1210

If you either use the official Firefox build, or install the languages as it suggests there, then I think this will go away.

Component: Preferences → Search
Flags: needinfo?(standard8) → needinfo?(neon3k+bugzilla)

In the past I had to install after every update the language again in the setting tab of Firefox, but the last update was ok so I think language issue was solved. I install firefox with the AppCenter of elementaryOS (Ubuntu). According to about tab "83.0 (64 bit) Mozilla Firefox for Ubuntu canonical 1.0). So yes it is probably the same issue...

Flags: needinfo?(neon3k+bugzilla)

Thank you for the response. I'm going to close this as "moved" to refer to the fact this is an issue with the ElementaryOS, as referred to here: https://github.com/elementary/appcenter/issues/1210

Unfortunately there isn't much we can do about this from Mozilla, as it does appear to be an issue with how the OS is set up - though if the developers need help, we will certainly be happy to try to do so.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago1 month ago
Resolution: --- → MOVED
Summary: After every update search providers is reset → After every update search providers is reset (elementaryOS)

@Mark Banner: Thanks for input. I deleted my reporter account for this bug at bugzilla because I assumed that all data will be deleted. But my login email address in the "Flags: needinfo?...." is still visible.
Can you please delete my email address from your database in bugzilla and all needinfo flags? Thanks!

Flags: needinfo?(standard8)

(In reply to bwd12fnphps@temp.mailbox.org from comment #20)

@Mark Banner: Thanks for input. I deleted my reporter account for this bug at bugzilla because I assumed that all data will be deleted. But my login email address in the "Flags: needinfo?...." is still visible.
Can you please delete my email address from your database in bugzilla and all needinfo flags? Thanks!

Please can you email bugzilla-admin@mozilla.org about this. It is probably a bug in bugzilla, but they may also have faster mitigations.

Flags: needinfo?(standard8)
You need to log in before you can comment on or make changes to this bug.