Closed Bug 1672140 Opened 1 year ago Closed 2 months ago

Find better naming for mozilla::dom::cache::QuotaInfo vs. mozilla::dom::quota::QuotaInfo

Categories

(Core :: Storage: Cache API, task)

task

Tracking

()

RESOLVED FIXED
96 Branch
Tracking Status
firefox96 --- fixed

People

(Reporter: sg, Assigned: hxu)

Details

Attachments

(3 files)

In both mozilla::dom::cache and mozilla::dom::quota, we have types called QuotaInfo, where the former subclasses the latter. The naming is quite generic, and probably at least one of the classes should be renamed.

There's no mozilla::dom::quota::QuotaInfo anymore, it's been renamed to mozilla::dom::quota::OriginMetadata.
However the one in cache should be renamed still I think and the inheritance can be changed from OriginMetadata to ClientMetadata.

Assignee: nobody → hxu
Attachment #9241174 - Attachment description: Bug 1672140 - Rename cache::QuotaInfo to cache::ClientMetadata and inherit it from quota::ClientMetadata; r=#dom-storage → Bug 1672140 - Rename cache::QuotaInfo to cache::ClientMetadata and rename corresponding functions; r=#dom-storage
Keywords: leave-open
Attachment #9251524 - Attachment description: Bug 1672140 - Rename cache::ClientMetadata to cache::ClientDirectoryMetadata; r=#dom-storage-reviewers → Bug 1672140 - Rename cache::ClientMetadata to cache::CacheDirectoryMetadata; r=#dom-storage-reviewers
Pushed by hxu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/396640d13ece
Rename cache::QuotaInfo to cache::ClientMetadata and rename corresponding functions; r=dom-storage-reviewers,janv
https://hg.mozilla.org/integration/autoland/rev/549556f430a7
Change cache::ClientMetadata's base class from quota::OriginMetadata to quota::ClientMetadata; r=dom-storage-reviewers,janv
https://hg.mozilla.org/integration/autoland/rev/32edbc243607
Rename cache::ClientMetadata to cache::CacheDirectoryMetadata; r=dom-storage-reviewers,janv
Keywords: leave-open
Pushed by hxu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/efab0b5de6f8
Rename cache::QuotaInfo to cache::ClientMetadata and rename corresponding functions; r=dom-storage-reviewers,janv
https://hg.mozilla.org/integration/autoland/rev/babad44d2c1f
Change cache::ClientMetadata's base class from quota::OriginMetadata to quota::ClientMetadata; r=dom-storage-reviewers,janv
https://hg.mozilla.org/integration/autoland/rev/5994ceff9c9a
Rename cache::ClientMetadata to cache::CacheDirectoryMetadata; r=dom-storage-reviewers,janv
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Build error fixed by the latest revision.

Flags: needinfo?(hxu)
You need to log in before you can comment on or make changes to this bug.